Read the docs
TI-2017-04649 Aliases CVE-2017-6923GHSA-v3f6-f29f-rgvp

Access bypass in Drupal 8 views

Priority LOW 33CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

In Drupal 8.x prior to 8.3.7 When creating a view, you can optionally use Ajax to update the displayed data via filter parameters. The views subsystem/module did not restrict access to the Ajax endpoint to only views configured to use Ajax. This is mitigated if you have access restrictions on the view. It is best practice to always include some form of access restrictions on all views, even if you are using another module to display them.

Why it matters now

EPSS 0.02022 81st percentileScored 2026-11-07
Fix Fixed Drupal core (Drupal): 8.3.7drupal/core (Packagist): 8.3.7+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalDrupal core8.x to before 8.3.78.3.7Patch availableCNA
—drupal/core (Packagist)8.0 to before 8.3.78.3.7Patch availableGHSA-v3f6-f29f-rgvp
—drupal/drupal (Packagist)8.0 to before 8.3.78.3.7Patch availableGHSA-v3f6-f29f-rgvp
  • Drupal core VendorDrupal Affected 8.x to before 8.3.7 Fixed in 8.3.7 Patch available CNA
  • drupal/core (Packagist) Vendor— Affected 8.0 to before 8.3.7 Fixed in 8.3.7 Patch available GHSA-v3f6-f29f-rgvp
  • drupal/drupal (Packagist) Vendor— Affected 8.0 to before 8.3.7 Fixed in 8.3.7 Patch available GHSA-v3f6-f29f-rgvp

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*8.0.0 – 8.3.7VulnerableDrupal
  • cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.0.0 – 8.3.7 Vulnerable ·Drupal

Remediation

  • Fix · CNA Drupal core (Drupal) Fixed in 8.3.7
  • Fix · GHSA-v3f6-f29f-rgvp drupal/core (Packagist) Fixed in 8.3.7 Advisory →
  • Fix · GHSA-v3f6-f29f-rgvp drupal/drupal (Packagist) Fixed in 8.3.7 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-6923
  2. 2026-10-03 Alias added: GHSA-v3f6-f29f-rgvp

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 278 →

Sources