Read the docs
TI-2017-04650 Aliases CVE-2017-6924GHSA-p8g6-5mg7-9r5q

REST API can bypass comment approval - Access Bypass - Moderately Critical

Priority LOW 37CWE-269Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Privilege escalation
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-269.

Summary

In Drupal 8 prior to 8.3.7; When using the REST API, users without the correct permission can post comments via REST that are approved even if the user does not have permission to post approved comments. This issue only affects sites that have the RESTful Web Services (rest) module enabled, the comment entity REST resource enabled, and where an attacker can access a user account on the site with permissions to post comments, or where anonymous users can post comments.

Why it matters now

EPSS 0.02102 81st percentileScored 2026-11-07
Fix Fixed Drupal Core (Drupal): 8.3.7drupal/core (Packagist): 8.3.7+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalDrupal CoreDrupal 8 to before 8.3.78.3.7Patch availableCNA
—drupal/core (Packagist)8.0 to before 8.3.78.3.7Patch availableGHSA-p8g6-5mg7-9r5q
—drupal/drupal (Packagist)8.0 to before 8.3.78.3.7Patch availableGHSA-p8g6-5mg7-9r5q
  • Drupal Core VendorDrupal Affected Drupal 8 to before 8.3.7 Fixed in 8.3.7 Patch available CNA
  • drupal/core (Packagist) Vendor— Affected 8.0 to before 8.3.7 Fixed in 8.3.7 Patch available GHSA-p8g6-5mg7-9r5q
  • drupal/drupal (Packagist) Vendor— Affected 8.0 to before 8.3.7 Fixed in 8.3.7 Patch available GHSA-p8g6-5mg7-9r5q

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*8.0.0 to before 8.3.7VulnerableDrupal
  • cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.0.0 to before 8.3.7 Vulnerable ·Drupal

Remediation

  • Fix · CNA Drupal Core (Drupal) Fixed in 8.3.7
  • Fix · GHSA-p8g6-5mg7-9r5q drupal/core (Packagist) Fixed in 8.3.7 Advisory →
  • Fix · GHSA-p8g6-5mg7-9r5q drupal/drupal (Packagist) Fixed in 8.3.7 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-6924
  2. 2026-10-03 Alias added: GHSA-p8g6-5mg7-9r5q

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 278 →

Sources