In versions of Drupal 8 core prior to 8.3.7; There is a vulnerability in the entity…
Priority MEDIUM 48CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
In versions of Drupal 8 core prior to 8.3.7; There is a vulnerability in the entity access system that could allow unwanted access to view, create, update, or delete entities. This only affects entities that do not use or do not have UUIDs, and entities that have different access restrictions on different revisions of the same entity.
Why it matters now
EPSS 0.03017 87th percentileScored 2026-11-07
Fix Fixed drupal/core (Packagist): 8.3.7drupal/drupal (Packagist): 8.3.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | drupal/core (Packagist) | 8.0 to before 8.3.7 | 8.3.7 | Patch available | GHSA-f4qx-jqfq-7785 |
| — | drupal/drupal (Packagist) | 8.0 to before 8.3.7 | 8.3.7 | Patch available | GHSA-f4qx-jqfq-7785 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- drupal/core (Packagist) Vendor— Affected 8.0 to before 8.3.7 Fixed in 8.3.7 Patch available GHSA-f4qx-jqfq-7785
- drupal/drupal (Packagist) Vendor— Affected 8.0 to before 8.3.7 Fixed in 8.3.7 Patch available GHSA-f4qx-jqfq-7785
Remediation
- Fix · GHSA-f4qx-jqfq-7785 drupal/core (Packagist) Fixed in 8.3.7 Advisory →
- Fix · GHSA-f4qx-jqfq-7785 drupal/drupal (Packagist) Fixed in 8.3.7 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-6925
- 2026-10-03 Alias added: GHSA-f4qx-jqfq-7785
References
Advisory 2
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2017-6925 · CVE Program
- CVE-2017-6925 · NVD
- FIRST EPSS
- GHSA-f4qx-jqfq-7785 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-6925 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences