Read the docs
TI-2017-04656 Aliases CVE-2017-6930GHSA-3327-jr93-7hq3

Improper access control in Drupal Core

Priority LOW 38CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.

Summary

In Drupal versions 8.4.x versions before 8.4.5 when using node access controls with a multilingual site, Drupal marks the untranslated version of a node as the default fallback for access queries. This fallback is used for languages that do not yet have a translated version of the created node. This can result in an access bypass vulnerability. This issue is mitigated by the fact that it only applies to sites that a) use the Content Translation module; and b) use a node access module such as Domain Access which implement hook_node_access_records().

Why it matters now

EPSS 0.01286 70th percentileScored 2026-11-07
Fix Fixed drupal/core (Packagist): 8.4.5drupal/drupal (Packagist): 8.4.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalDrupal Core8.4.x versions before 8.4.5—No fix listedCNA
—drupal/core (Packagist)8.4.0 to before 8.4.58.4.5Patch availableGHSA-3327-jr93-7hq3
—drupal/drupal (Packagist)8.4.0 to before 8.4.58.4.5Patch availableGHSA-3327-jr93-7hq3
  • Drupal Core VendorDrupal Affected 8.4.x versions before 8.4.5 Fixed in — No fix listed CNA
  • drupal/core (Packagist) Vendor— Affected 8.4.0 to before 8.4.5 Fixed in 8.4.5 Patch available GHSA-3327-jr93-7hq3
  • drupal/drupal (Packagist) Vendor— Affected 8.4.0 to before 8.4.5 Fixed in 8.4.5 Patch available GHSA-3327-jr93-7hq3

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*8.4.0 to before 8.4.5VulnerableDrupal
  • cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.4.0 to before 8.4.5 Vulnerable ·Drupal

Remediation

  • Fix · GHSA-3327-jr93-7hq3 drupal/core (Packagist) Fixed in 8.4.5 Advisory →
  • Fix · GHSA-3327-jr93-7hq3 drupal/drupal (Packagist) Fixed in 8.4.5 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-6930
  2. 2026-10-03 Alias added: GHSA-3327-jr93-7hq3

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 278 →

Sources