Read the docs

British Columbia Institute of Technology CodeIgniter 3.1.3 is vulnerable to HTTP Header…

Priority LOW 35CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

British Columbia Institute of Technology CodeIgniter 3.1.3 is vulnerable to HTTP Header Injection in the set_status_header() common function under Apache resulting in HTTP Header Injection flaws.

Why it matters now

EPSS 0.00931 60th percentileScored 2026-11-07
Fix Fixed codeigniter4/framework (Packagist): 3.1.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—codeigniter4/framework (Packagist)3.1.3 to before 3.1.43.1.4Patch availableGHSA-j9f9-8j39-4g97
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • codeigniter4/framework (Packagist) Vendor— Affected 3.1.3 to before 3.1.4 Fixed in 3.1.4 Patch available GHSA-j9f9-8j39-4g97

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:codeigniter:codeigniter:3.1.3:*:*:*:*:*:*:*3.1.3Vulnerablecodeigniter4
  • cpe:2.3:a:codeigniter:codeigniter:3.1.3:*:*:*:*:*:*:* Versions 3.1.3 Vulnerable ·codeigniter4

Remediation

  • Fix · GHSA-j9f9-8j39-4g97 codeigniter4/framework (Packagist) Fixed in 3.1.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000247
  2. 2026-10-03 Alias added: GHSA-j9f9-8j39-4g97

References

  • TI-2014-07135 CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it… CVSS 3.0CRITICAL 9.8
  • TI-2022-16370 SameSite may allow cross-site request forgery (CSRF) protection to be bypassed CVSS 3.1HIGH 8.8
  • TI-2022-06025 Deserialization of Untrusted Data in Codeigniter4 CVSS 3.1CRITICAL 9.8
  • TI-2024-27591 A Cross-Site Request Forgery (CSRF) in Codeigniter 3.1.13 allows attackers to arbitrarily… CVSS 3.1HIGH 7.5
  • TI-2014-07136 CodeIgniter before 2.2.0 makes it easier for attackers to decode session cookies by… CVSS 3.0CRITICAL 9.8
  • TI-2024-19671 CodeIgniter4 Language class DoS Vulnerability CVSS 3.1HIGH 7.5
See all 39 →

Sources