A Session Fixation issue exists in CodeIgniter before 3.1.9 because…
Priority MEDIUM 45CWE-384Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-384.
Summary
A Session Fixation issue exists in CodeIgniter before 3.1.9 because session.use_strict_mode in the Session Library was mishandled.
Why it matters now
EPSS 0.01504 74th percentileScored 2026-11-07
Fix Fixed codeigniter/framework (Packagist): 3.1.10
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | codeigniter/framework (Packagist) | before 3.1.10 | 3.1.10 | Patch available | GHSA-g434-3q2j-hj4r |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- codeigniter/framework (Packagist) Vendor— Affected before 3.1.10 Fixed in 3.1.10 Patch available GHSA-g434-3q2j-hj4r
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:* | before 3.1.9 | Vulnerable | codeigniter4 |
- cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:* Versions before 3.1.9 Vulnerable ·codeigniter4
Remediation
- Fix · GHSA-g434-3q2j-hj4r codeigniter/framework (Packagist) Fixed in 3.1.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-12071
- 2026-10-03 Alias added: GHSA-g434-3q2j-hj4r
References
Advisory 2
Other 5
- https://github.com/bcit-ci/CodeIgniter/commit/800a20d6c4662d99ae0988b2f8f2238bb8bb29db
- https://github.com/bcit-ci/CodeIgniter/issues/5958
- https://github.com/bcit-ci/CodeIgniter/commit/a9da3dd2f16a8f97d7bc4ff5572b28e4bb84c813#diff-32788a4d3748e8818044886ab43241179c7f5f5b82e979e73146669ca6e2da1cR306
- https://github.com/bcit-ci/CodeIgniter
- https://web.archive.org/web/20181115214804/https://www.codeigniter.com/user_guide/changelog.html#version-3-1-9
More codeigniter4 Codeigniter vulnerabilities
- TI-2014-07135 CodeIgniter before 3.0 and Kohana 3.2.3 and earlier and 3.3.x through 3.3.2 make it… CVSS 3.0CRITICAL 9.8
- TI-2022-16370 SameSite may allow cross-site request forgery (CSRF) protection to be bypassed CVSS 3.1HIGH 8.8
- TI-2022-06025 Deserialization of Untrusted Data in Codeigniter4 CVSS 3.1CRITICAL 9.8
- TI-2024-27591 A Cross-Site Request Forgery (CSRF) in Codeigniter 3.1.13 allows attackers to arbitrarily… CVSS 3.1HIGH 7.5
- TI-2014-07136 CodeIgniter before 2.2.0 makes it easier for attackers to decode session cookies by… CVSS 3.0CRITICAL 9.8
- TI-2024-19671 CodeIgniter4 Language class DoS Vulnerability CVSS 3.1HIGH 7.5
Sources
- CVE-2018-12071 · CVE Program
- CVE-2018-12071 · NVD
- FIRST EPSS
- GHSA-g434-3q2j-hj4r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences