Drupal core - Moderately critical - Cross Site Scripting - SA-CORE-2019-004
Priority LOW 38CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Drupal 7 versions prior to 7.65; Drupal 8.6 versions prior to 8.6.13;Drupal 8.5 versions prior to 8.5.14. Under certain circumstances the File module/subsystem allows a malicious user to upload a file that can trigger a cross-site scripting (XSS) vulnerability.
Why it matters now
EPSS 0.12187 96th percentileScored 2026-11-07
Fix Fixed Drupal core (Drupal): 7.65, 8.6.13, 8.5.14drupal/core (Packagist): 7.65.0, 8.5.14, 8.6.13+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal core | Drupal 7 to before 7.65; Drupal 8.6 to before 8.6.13; Drupal 8.5 to before 8.5.14 | 7.65, 8.6.13, 8.5.14 | Patch available | CNA |
| — | drupal/core (Packagist) | 7.0.0 to before 7.65.0 | 7.65.0 | Patch available | GHSA-cmmh-8mwp-gq5p |
| — | drupal/core (Packagist) | 8.0.0 to before 8.5.14 | 8.5.14 | Patch available | GHSA-cmmh-8mwp-gq5p |
| — | drupal/core (Packagist) | 8.6.0 to before 8.6.13 | 8.6.13 | Patch available | GHSA-cmmh-8mwp-gq5p |
| — | drupal/drupal (Packagist) | 7.0.0 to before 7.65.0 | 7.65.0 | Patch available | GHSA-cmmh-8mwp-gq5p |
| — | drupal/drupal (Packagist) | 8.0.0 to before 8.5.14 | 8.5.14 | Patch available | GHSA-cmmh-8mwp-gq5p |
| — | drupal/drupal (Packagist) | 8.6.0 to before 8.6.13 | 8.6.13 | Patch available | GHSA-cmmh-8mwp-gq5p |
- Drupal core VendorDrupal Affected Drupal 7 to before 7.65; Drupal 8.6 to before 8.6.13; Drupal 8.5 to before 8.5.14 Fixed in 7.65, 8.6.13, 8.5.14 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 7.0.0 to before 7.65.0 Fixed in 7.65.0 Patch available GHSA-cmmh-8mwp-gq5p
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 8.5.14 Fixed in 8.5.14 Patch available GHSA-cmmh-8mwp-gq5p
- drupal/core (Packagist) Vendor— Affected 8.6.0 to before 8.6.13 Fixed in 8.6.13 Patch available GHSA-cmmh-8mwp-gq5p
- drupal/drupal (Packagist) Vendor— Affected 7.0.0 to before 7.65.0 Fixed in 7.65.0 Patch available GHSA-cmmh-8mwp-gq5p
- drupal/drupal (Packagist) Vendor— Affected 8.0.0 to before 8.5.14 Fixed in 8.5.14 Patch available GHSA-cmmh-8mwp-gq5p
- drupal/drupal (Packagist) Vendor— Affected 8.6.0 to before 8.6.13 Fixed in 8.6.13 Patch available GHSA-cmmh-8mwp-gq5p
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 7.0 to before 7.65; 8.5.0 to before 8.5.14; 8.6.0 to before 8.6.13 | Vulnerable | Drupal |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:28:*:*:*:*:*:*:* | 28 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:29:*:*:*:*:*:*:* | 29 | Vulnerable | Fedoraproject |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 7.0 to before 7.65; 8.5.0 to before 8.5.14; 8.6.0 to before 8.6.13 Vulnerable ·Drupal
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:28:*:*:*:*:*:*:* Versions 28 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:29:*:*:*:*:*:*:* Versions 29 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA Drupal core (Drupal) Fixed in 7.65, 8.6.13, 8.5.14
- Fix · GHSA-cmmh-8mwp-gq5p drupal/core (Packagist) Fixed in 7.65.0 Advisory →
- Fix · GHSA-cmmh-8mwp-gq5p drupal/core (Packagist) Fixed in 8.5.14 Advisory →
- Fix · GHSA-cmmh-8mwp-gq5p drupal/core (Packagist) Fixed in 8.6.13 Advisory →
- Fix · GHSA-cmmh-8mwp-gq5p drupal/drupal (Packagist) Fixed in 7.65.0 Advisory →
- Fix · GHSA-cmmh-8mwp-gq5p drupal/drupal (Packagist) Fixed in 8.5.14 Advisory →
- Fix · GHSA-cmmh-8mwp-gq5p drupal/drupal (Packagist) Fixed in 8.6.13 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-6341
- 2026-10-03 Alias added: GHSA-cmmh-8mwp-gq5p
References
Advisory 6
Other 12
- https://www.synology.com/security/advisory/Synology_SA_19_13
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2019-6341.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2019-6341.yaml
- https://github.com/drupal/core
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IWHF4LALNBZCXMITWWVWKY3PNVYTM3N7
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/P4KTET2PTSIS3ZZ4SGBRQEN6CCLV5SYX
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QNTLCBAN6T7WYR5C4TNEYQD65IIR3V4P
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Y4SVTVIJ33XCFQ6X6XTVMQM3NPLP2WFS
- https://lists.fedoraproject.org/archives/list/[email protected]/message/IWHF4LALNBZCXMITWWVWKY3PNVYTM3N7
- https://lists.fedoraproject.org/archives/list/[email protected]/message/P4KTET2PTSIS3ZZ4SGBRQEN6CCLV5SYX
- https://lists.fedoraproject.org/archives/list/[email protected]/message/QNTLCBAN6T7WYR5C4TNEYQD65IIR3V4P
- https://lists.fedoraproject.org/archives/list/[email protected]/message/Y4SVTVIJ33XCFQ6X6XTVMQM3NPLP2WFS
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2019-6341 · CVE Program
- CVE-2019-6341 · NVD
- FIRST EPSS
- GHSA-cmmh-8mwp-gq5p · GitHub Advisory Database · CC BY 4.0
- CVE-2019-6341 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences