Cross-site scripting in tinymce
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
tinymce 4.7.11, 4.7.12 is affected by: CWE-79: Improper Neutralization of Input During Web Page Generation. The impact is: JavaScript code execution. The component is: Media element. The attack vector is: The victim must paste malicious content to media element's embed tab.
Why it matters now
EPSS 0.01917 79th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tinymce (npm): 4.9.10, 5.2.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tinymce | tinymce | 4.7.11, 4.7.12 | — | No fix listed | CNA |
| — | tinymce (npm) | before 4.9.10 | 4.9.10 | Patch available | GHSA-c78w-2gw7-gjv3 |
| — | tinymce (npm) | 5.0.0 to before 5.2.2 | 5.2.2 | Patch available | GHSA-c78w-2gw7-gjv3 |
- tinymce Vendortinymce Affected 4.7.11, 4.7.12 Fixed in — No fix listed CNA
- tinymce (npm) Vendor— Affected before 4.9.10 Fixed in 4.9.10 Patch available GHSA-c78w-2gw7-gjv3
- tinymce (npm) Vendor— Affected 5.0.0 to before 5.2.2 Fixed in 5.2.2 Patch available GHSA-c78w-2gw7-gjv3
Remediation
- Fix · GHSA-c78w-2gw7-gjv3 tinymce (npm) Fixed in 4.9.10 Advisory →
- Fix · GHSA-c78w-2gw7-gjv3 tinymce (npm) Fixed in 5.2.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1010091
- 2026-10-03 Alias added: GHSA-c78w-2gw7-gjv3
References
More tinymce vulnerabilities
- TI-2011-04153 Static code injection vulnerability in inc/function.base.php in Ajax File and Image… CVSS 2.0HIGH 7.5
- TI-2026-81439 Cross-site scripting in TinyMCE media plugin via data-mce-object CVSS 4.0HIGH 8.5
- TI-2026-35259 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments CVSS 3.1HIGH 8.7
- TI-2026-35258 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection CVSS 3.1HIGH 8.7
- TI-2026-35256 TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes CVSS 3.1HIGH 8.7
- TI-2026-35257 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs CVSS 3.1HIGH 8.7
Sources
- CVE-2019-1010091 · CVE Program
- CVE-2019-1010091 · NVD
- FIRST EPSS
- GHSA-c78w-2gw7-gjv3 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-1010091 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences