Cross-site request forgery in Drupal Core
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Cross Site Request Forgery vulnerability in Drupal Core Form API does not properly handle certain form input from cross-site requests, which can lead to other vulnerabilities.
Why it matters now
EPSS 0.00695 53rd percentileScored 2026-11-07
Fix Fixed Drupal Core (Drupal): 7.72, 8.8.8, 8.9.1 +1drupal/core (Packagist): 8.9.1, 9.0.1, 7.72 +1+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal Core | 7.x to before 7.72; 8.8.x to before 8.8.8; 8.9.x to before 8.9.1; 9.0.x to before 9.0.1 | 7.72, 8.8.8, 8.9.1, 9.0.1 | Patch available | CNA |
| — | drupal/core (Packagist) | 8.9.0 to before 8.9.1 | 8.9.1 | Patch available | GHSA-m648-hpf8-qcjw |
| — | drupal/core (Packagist) | 9.0.0 to before 9.0.1 | 9.0.1 | Patch available | GHSA-m648-hpf8-qcjw |
| — | drupal/core (Packagist) | 7.0.0 to before 7.72 | 7.72 | Patch available | GHSA-m648-hpf8-qcjw |
| — | drupal/core (Packagist) | 8.0.0 to before 8.8.8 | 8.8.8 | Patch available | GHSA-m648-hpf8-qcjw |
| — | drupal/drupal (Packagist) | 7.0.0 to before 7.72 | 7.72 | Patch available | GHSA-m648-hpf8-qcjw |
| — | drupal/drupal (Packagist) | 8.0.0 to before 8.8.8 | 8.8.8 | Patch available | GHSA-m648-hpf8-qcjw |
| — | drupal/drupal (Packagist) | 8.9.0 to before 8.9.1 | 8.9.1 | Patch available | GHSA-m648-hpf8-qcjw |
| — | drupal/drupal (Packagist) | 9.0.0 to before 9.0.1 | 9.0.1 | Patch available | GHSA-m648-hpf8-qcjw |
- Drupal Core VendorDrupal Affected 7.x to before 7.72; 8.8.x to before 8.8.8; 8.9.x to before 8.9.1; 9.0.x to before 9.0.1 Fixed in 7.72, 8.8.8, 8.9.1, 9.0.1 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 8.9.0 to before 8.9.1 Fixed in 8.9.1 Patch available GHSA-m648-hpf8-qcjw
- drupal/core (Packagist) Vendor— Affected 9.0.0 to before 9.0.1 Fixed in 9.0.1 Patch available GHSA-m648-hpf8-qcjw
- drupal/core (Packagist) Vendor— Affected 7.0.0 to before 7.72 Fixed in 7.72 Patch available GHSA-m648-hpf8-qcjw
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 8.8.8 Fixed in 8.8.8 Patch available GHSA-m648-hpf8-qcjw
- drupal/drupal (Packagist) Vendor— Affected 7.0.0 to before 7.72 Fixed in 7.72 Patch available GHSA-m648-hpf8-qcjw
- drupal/drupal (Packagist) Vendor— Affected 8.0.0 to before 8.8.8 Fixed in 8.8.8 Patch available GHSA-m648-hpf8-qcjw
- drupal/drupal (Packagist) Vendor— Affected 8.9.0 to before 8.9.1 Fixed in 8.9.1 Patch available GHSA-m648-hpf8-qcjw
- drupal/drupal (Packagist) Vendor— Affected 9.0.0 to before 9.0.1 Fixed in 9.0.1 Patch available GHSA-m648-hpf8-qcjw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 7.0 to before 7.72; 8.8.0 to before 8.8.8; 8.9.0 to before 8.9.1; 9.0.0 to before 9.0.1 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 7.0 to before 7.72; 8.8.0 to before 8.8.8; 8.9.0 to before 8.9.1; 9.0.0 to before 9.0.1 Vulnerable ·Drupal
Remediation
- Fix · CNA Drupal Core (Drupal) Fixed in 7.72, 8.8.8, 8.9.1, 9.0.1
- Fix · GHSA-m648-hpf8-qcjw drupal/core (Packagist) Fixed in 8.9.1 Advisory →
- Fix · GHSA-m648-hpf8-qcjw drupal/core (Packagist) Fixed in 9.0.1 Advisory →
- Fix · GHSA-m648-hpf8-qcjw drupal/core (Packagist) Fixed in 7.72 Advisory →
- Fix · GHSA-m648-hpf8-qcjw drupal/core (Packagist) Fixed in 8.8.8 Advisory →
- Fix · GHSA-m648-hpf8-qcjw drupal/drupal (Packagist) Fixed in 7.72 Advisory →
- Fix · GHSA-m648-hpf8-qcjw drupal/drupal (Packagist) Fixed in 8.8.8 Advisory →
- Fix · GHSA-m648-hpf8-qcjw drupal/drupal (Packagist) Fixed in 8.9.1 Advisory →
- Fix · GHSA-m648-hpf8-qcjw drupal/drupal (Packagist) Fixed in 9.0.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-13663
- 2026-10-03 Alias added: GHSA-m648-hpf8-qcjw
References
Other 6
- https://github.com/drupal/core/commit/5f3c4d80fd77df0cfa87722b446db54040d55693
- https://github.com/drupal/core/commit/bc3235dcb5570bbda62ef9547e7604ee060b72c6
- https://github.com/drupal/core/commit/faf3243c4ce03bbaab386af2b272b363fd0dfddb
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2020-13663.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2020-13663.yaml
- https://github.com/drupal/core
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2020-13663 · CVE Program
- CVE-2020-13663 · NVD
- FIRST EPSS
- GHSA-m648-hpf8-qcjw · GitHub Advisory Database · CC BY 4.0
- CVE-2020-13663 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences