Incorrect authorization in Drupal Core
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Access bypass vulnerability in Drupal Core allows JSON:API when JSON:API is in read/write mode. Only sites that have the read_only set to FALSE under jsonapi.settings config are vulnerable. This issue affects: Drupal Drupal Core 8.8.x versions prior to 8.8.8; 8.9.x versions prior to 8.9.1; 9.0.x versions prior to 9.0.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal Core | 8.8.x to before 8.8.8; 8.9.x to before 8.9.1; 9.0.x to before 9.0.1 | 8.8.8, 8.9.1, 9.0.1 | Patch available | CNA |
| — | drupal/core (Packagist) | 8.8.0 to before 8.8.8 | 8.8.8 | Patch available | GHSA-wxqp-jwc9-g39x |
| — | drupal/core (Packagist) | 8.9.0 to before 8.9.1 | 8.9.1 | Patch available | GHSA-wxqp-jwc9-g39x |
| — | drupal/core (Packagist) | 9.0.0 to before 9.0.1 | 9.0.1 | Patch available | GHSA-wxqp-jwc9-g39x |
| — | drupal/drupal (Packagist) | 8.8.0 to before 8.8.8 | 8.8.8 | Patch available | GHSA-wxqp-jwc9-g39x |
| — | drupal/drupal (Packagist) | 8.9.0 to before 8.9.1 | 8.9.1 | Patch available | GHSA-wxqp-jwc9-g39x |
| — | drupal/drupal (Packagist) | 9.0.0 to before 9.0.1 | 9.0.1 | Patch available | GHSA-wxqp-jwc9-g39x |
- Drupal Core VendorDrupal Affected 8.8.x to before 8.8.8; 8.9.x to before 8.9.1; 9.0.x to before 9.0.1 Fixed in 8.8.8, 8.9.1, 9.0.1 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 8.8.0 to before 8.8.8 Fixed in 8.8.8 Patch available GHSA-wxqp-jwc9-g39x
- drupal/core (Packagist) Vendor— Affected 8.9.0 to before 8.9.1 Fixed in 8.9.1 Patch available GHSA-wxqp-jwc9-g39x
- drupal/core (Packagist) Vendor— Affected 9.0.0 to before 9.0.1 Fixed in 9.0.1 Patch available GHSA-wxqp-jwc9-g39x
- drupal/drupal (Packagist) Vendor— Affected 8.8.0 to before 8.8.8 Fixed in 8.8.8 Patch available GHSA-wxqp-jwc9-g39x
- drupal/drupal (Packagist) Vendor— Affected 8.9.0 to before 8.9.1 Fixed in 8.9.1 Patch available GHSA-wxqp-jwc9-g39x
- drupal/drupal (Packagist) Vendor— Affected 9.0.0 to before 9.0.1 Fixed in 9.0.1 Patch available GHSA-wxqp-jwc9-g39x
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 8.8.0 to before 8.8.8; 8.9.0 to before 8.9.1; 9.0.0 to before 9.0.1 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.8.0 to before 8.8.8; 8.9.0 to before 8.9.1; 9.0.0 to before 9.0.1 Vulnerable ·Drupal
Remediation
- Fix · CNA Drupal Core (Drupal) Fixed in 8.8.8, 8.9.1, 9.0.1
- Fix · GHSA-wxqp-jwc9-g39x drupal/core (Packagist) Fixed in 8.8.8 Advisory →
- Fix · GHSA-wxqp-jwc9-g39x drupal/core (Packagist) Fixed in 8.9.1 Advisory →
- Fix · GHSA-wxqp-jwc9-g39x drupal/core (Packagist) Fixed in 9.0.1 Advisory →
- Fix · GHSA-wxqp-jwc9-g39x drupal/drupal (Packagist) Fixed in 8.8.8 Advisory →
- Fix · GHSA-wxqp-jwc9-g39x drupal/drupal (Packagist) Fixed in 8.9.1 Advisory →
- Fix · GHSA-wxqp-jwc9-g39x drupal/drupal (Packagist) Fixed in 9.0.1 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal Core 8.8.8, 8.9.1, 9.0.1
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2020-10724 Command injection in Drupal CorePriority MEDIUM 43
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-13665
- 2026-10-03 Alias added: GHSA-wxqp-jwc9-g39x
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2020-13665 · CVE Program
- CVE-2020-13665 · NVD
- FIRST EPSS
- GHSA-wxqp-jwc9-g39x · GitHub Advisory Database · CC BY 4.0
- CVE-2020-13665 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences