Incorrect default permissions in Drupal Core
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Access bypass vulnerability in of Drupal Core Workspaces allows an attacker to access data without correct permissions. The Workspaces module doesn't sufficiently check access permissions when switching workspaces, leading to an access bypass vulnerability. An attacker might be able to see content before the site owner intends people to see the content. This vulnerability is mitigated by the fact that sites are only vulnerable if they have installed the experimental Workspaces module. This issue affects Drupal Core8.8.X versions prior to 8.8.10; 8.9.X versions prior to 8.9.6; 9.0.X versions prior to 9.0.6.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal Core | 8.8.X to before 8.8.10; 8.9.X to before 8.9.6; 9.0.X to before 9.0.6 | 8.8.10, 8.9.6, 9.0.6 | Patch available | CNA |
| — | drupal/core (Packagist) | 8.8.0 to before 8.8.10 | 8.8.10 | Patch available | GHSA-x2q9-r8gm-f657 |
| — | drupal/core (Packagist) | 8.9.0 to before 8.9.6 | 8.9.6 | Patch available | GHSA-x2q9-r8gm-f657 |
| — | drupal/core (Packagist) | 9.0.0 to before 9.0.6 | 9.0.6 | Patch available | GHSA-x2q9-r8gm-f657 |
| — | drupal/drupal (Packagist) | 8.8.0 to before 8.8.10 | 8.8.10 | Patch available | GHSA-x2q9-r8gm-f657 |
| — | drupal/drupal (Packagist) | 8.9.0 to before 8.9.6 | 8.9.6 | Patch available | GHSA-x2q9-r8gm-f657 |
| — | drupal/drupal (Packagist) | 9.0.0 to before 9.0.6 | 9.0.6 | Patch available | GHSA-x2q9-r8gm-f657 |
- Drupal Core VendorDrupal Affected 8.8.X to before 8.8.10; 8.9.X to before 8.9.6; 9.0.X to before 9.0.6 Fixed in 8.8.10, 8.9.6, 9.0.6 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 8.8.0 to before 8.8.10 Fixed in 8.8.10 Patch available GHSA-x2q9-r8gm-f657
- drupal/core (Packagist) Vendor— Affected 8.9.0 to before 8.9.6 Fixed in 8.9.6 Patch available GHSA-x2q9-r8gm-f657
- drupal/core (Packagist) Vendor— Affected 9.0.0 to before 9.0.6 Fixed in 9.0.6 Patch available GHSA-x2q9-r8gm-f657
- drupal/drupal (Packagist) Vendor— Affected 8.8.0 to before 8.8.10 Fixed in 8.8.10 Patch available GHSA-x2q9-r8gm-f657
- drupal/drupal (Packagist) Vendor— Affected 8.9.0 to before 8.9.6 Fixed in 8.9.6 Patch available GHSA-x2q9-r8gm-f657
- drupal/drupal (Packagist) Vendor— Affected 9.0.0 to before 9.0.6 Fixed in 9.0.6 Patch available GHSA-x2q9-r8gm-f657
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 8.8.0 to before 8.8.10; 8.9.0 to before 8.9.6; 9.0.0 to before 9.0.6 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.8.0 to before 8.8.10; 8.9.0 to before 8.9.6; 9.0.0 to before 9.0.6 Vulnerable ·Drupal
Remediation
- Fix · CNA Drupal Core (Drupal) Fixed in 8.8.10, 8.9.6, 9.0.6
- Fix · GHSA-x2q9-r8gm-f657 drupal/core (Packagist) Fixed in 8.8.10 Advisory →
- Fix · GHSA-x2q9-r8gm-f657 drupal/core (Packagist) Fixed in 8.9.6 Advisory →
- Fix · GHSA-x2q9-r8gm-f657 drupal/core (Packagist) Fixed in 9.0.6 Advisory →
- Fix · GHSA-x2q9-r8gm-f657 drupal/drupal (Packagist) Fixed in 8.8.10 Advisory →
- Fix · GHSA-x2q9-r8gm-f657 drupal/drupal (Packagist) Fixed in 8.9.6 Advisory →
- Fix · GHSA-x2q9-r8gm-f657 drupal/drupal (Packagist) Fixed in 9.0.6 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-13667
- 2026-10-03 Alias added: GHSA-x2q9-r8gm-f657
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2020-13667 · CVE Program
- CVE-2020-13667 · NVD
- FIRST EPSS
- GHSA-x2q9-r8gm-f657 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-13667 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences