Cross-site scripting in Drupal Core
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site Scripting (XSS) vulnerability in ckeditor of Drupal Core allows attacker to inject XSS. This issue affects: Drupal Core 8.8.x versions prior to 8.8.10.; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Core | 8.8.x to before 8.8.10; 8.9.x to before 8.9.6; 9.0.x to before 9.0.6 | 8.8.10, 8.9.6, 9.0.6 | Patch available | CNA |
| — | drupal/core (Packagist) | 8.0.0 to before 8.8.10 | 8.8.10 | Patch available | GHSA-c533-c843-67h8 |
| — | drupal/core (Packagist) | 8.9.0 to before 8.9.6 | 8.9.6 | Patch available | GHSA-c533-c843-67h8 |
| — | drupal/core (Packagist) | 9.0.0 to before 9.0.6 | 9.0.6 | Patch available | GHSA-c533-c843-67h8 |
| — | drupal/drupal (Packagist) | 8.0.0 to before 8.8.10 | 8.8.10 | Patch available | GHSA-c533-c843-67h8 |
| — | drupal/drupal (Packagist) | 8.9.0 to before 8.9.6 | 8.9.6 | Patch available | GHSA-c533-c843-67h8 |
| — | drupal/drupal (Packagist) | 9.0.0 to before 9.0.6 | 9.0.6 | Patch available | GHSA-c533-c843-67h8 |
- Core VendorDrupal Affected 8.8.x to before 8.8.10; 8.9.x to before 8.9.6; 9.0.x to before 9.0.6 Fixed in 8.8.10, 8.9.6, 9.0.6 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 8.8.10 Fixed in 8.8.10 Patch available GHSA-c533-c843-67h8
- drupal/core (Packagist) Vendor— Affected 8.9.0 to before 8.9.6 Fixed in 8.9.6 Patch available GHSA-c533-c843-67h8
- drupal/core (Packagist) Vendor— Affected 9.0.0 to before 9.0.6 Fixed in 9.0.6 Patch available GHSA-c533-c843-67h8
- drupal/drupal (Packagist) Vendor— Affected 8.0.0 to before 8.8.10 Fixed in 8.8.10 Patch available GHSA-c533-c843-67h8
- drupal/drupal (Packagist) Vendor— Affected 8.9.0 to before 8.9.6 Fixed in 8.9.6 Patch available GHSA-c533-c843-67h8
- drupal/drupal (Packagist) Vendor— Affected 9.0.0 to before 9.0.6 Fixed in 9.0.6 Patch available GHSA-c533-c843-67h8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 8.8.0 to before 8.8.10; 8.9.0 to before 8.9.6; 9.0.0 to before 9.0.6 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.8.0 to before 8.8.10; 8.9.0 to before 8.9.6; 9.0.0 to before 9.0.6 Vulnerable ·Drupal
Remediation
- Fix · CNA Core (Drupal) Fixed in 8.8.10, 8.9.6, 9.0.6
- Fix · GHSA-c533-c843-67h8 drupal/core (Packagist) Fixed in 8.8.10 Advisory →
- Fix · GHSA-c533-c843-67h8 drupal/core (Packagist) Fixed in 8.9.6 Advisory →
- Fix · GHSA-c533-c843-67h8 drupal/core (Packagist) Fixed in 9.0.6 Advisory →
- Fix · GHSA-c533-c843-67h8 drupal/drupal (Packagist) Fixed in 8.8.10 Advisory →
- Fix · GHSA-c533-c843-67h8 drupal/drupal (Packagist) Fixed in 8.9.6 Advisory →
- Fix · GHSA-c533-c843-67h8 drupal/drupal (Packagist) Fixed in 9.0.6 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Drupal Core 8.8.10, 8.9.6, 9.0.6
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2020-10730 Exposure of resource to wrong sphere in Drupal CorePriority LOW 35
- TI-2020-10728 Access bypass in Drupal Core 8/9Priority LOW 29
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-13669
- 2026-10-03 Alias added: GHSA-c533-c843-67h8
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2020-13669 · CVE Program
- CVE-2020-13669 · NVD
- FIRST EPSS
- GHSA-c533-c843-67h8 · GitHub Advisory Database · CC BY 4.0
- CVE-2020-13669 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences