Cross-site scripting in Drupal Core
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site Scripting (XSS) vulnerability in Drupal core's sanitization API fails to properly filter cross-site scripting under certain circumstances. This issue affects: Drupal Core 9.1.x versions prior to 9.1.7; 9.0.x versions prior to 9.0.12; 8.9.x versions prior to 8.9.14; 7.x versions prior to 7.80.
Why it matters now
EPSS 0.00677 52nd percentileScored 2026-11-07
Fix Fixed Core (Drupal): 9.1.7, 9.0.12, 8.9.14 +1drupal/core (Packagist): 7.80, 8.9.14, 9.0.12 +1+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Core | 9.1.x to before 9.1.7; 9.0.x to before 9.0.12; 8.9.x to before 8.9.14; 7.x to before 7.80 | 9.1.7, 9.0.12, 8.9.14, 7.80 | Patch available | CNA |
| — | drupal/core (Packagist) | 7.0.0 to before 7.80 | 7.80 | Patch available | GHSA-3m36-mjwj-352c |
| — | drupal/core (Packagist) | 8.0.0 to before 8.9.14 | 8.9.14 | Patch available | GHSA-3m36-mjwj-352c |
| — | drupal/core (Packagist) | 9.0.0 to before 9.0.12 | 9.0.12 | Patch available | GHSA-3m36-mjwj-352c |
| — | drupal/core (Packagist) | 9.1.0 to before 9.1.7 | 9.1.7 | Patch available | GHSA-3m36-mjwj-352c |
| — | drupal/drupal (Packagist) | 7.0.0 to before 7.80 | 7.80 | Patch available | GHSA-3m36-mjwj-352c |
| — | drupal/drupal (Packagist) | 8.0.0 to before 8.9.14 | 8.9.14 | Patch available | GHSA-3m36-mjwj-352c |
| — | drupal/drupal (Packagist) | 9.0.0 to before 9.0.12 | 9.0.12 | Patch available | GHSA-3m36-mjwj-352c |
| — | drupal/drupal (Packagist) | 9.1.0 to before 9.1.7 | 9.1.7 | Patch available | GHSA-3m36-mjwj-352c |
- Core VendorDrupal Affected 9.1.x to before 9.1.7; 9.0.x to before 9.0.12; 8.9.x to before 8.9.14; 7.x to before 7.80 Fixed in 9.1.7, 9.0.12, 8.9.14, 7.80 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 7.0.0 to before 7.80 Fixed in 7.80 Patch available GHSA-3m36-mjwj-352c
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 8.9.14 Fixed in 8.9.14 Patch available GHSA-3m36-mjwj-352c
- drupal/core (Packagist) Vendor— Affected 9.0.0 to before 9.0.12 Fixed in 9.0.12 Patch available GHSA-3m36-mjwj-352c
- drupal/core (Packagist) Vendor— Affected 9.1.0 to before 9.1.7 Fixed in 9.1.7 Patch available GHSA-3m36-mjwj-352c
- drupal/drupal (Packagist) Vendor— Affected 7.0.0 to before 7.80 Fixed in 7.80 Patch available GHSA-3m36-mjwj-352c
- drupal/drupal (Packagist) Vendor— Affected 8.0.0 to before 8.9.14 Fixed in 8.9.14 Patch available GHSA-3m36-mjwj-352c
- drupal/drupal (Packagist) Vendor— Affected 9.0.0 to before 9.0.12 Fixed in 9.0.12 Patch available GHSA-3m36-mjwj-352c
- drupal/drupal (Packagist) Vendor— Affected 9.1.0 to before 9.1.7 Fixed in 9.1.7 Patch available GHSA-3m36-mjwj-352c
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | before 7.80; 8.9.0 to before 8.9.14; 9.0.0 to before 9.0.12; 9.1.0 to before 9.1.7 | Vulnerable | Drupal |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions before 7.80; 8.9.0 to before 8.9.14; 9.0.0 to before 9.0.12; 9.1.0 to before 9.1.7 Vulnerable ·Drupal
Remediation
- Fix · CNA Core (Drupal) Fixed in 9.1.7, 9.0.12, 8.9.14, 7.80
- Fix · GHSA-3m36-mjwj-352c drupal/core (Packagist) Fixed in 7.80 Advisory →
- Fix · GHSA-3m36-mjwj-352c drupal/core (Packagist) Fixed in 8.9.14 Advisory →
- Fix · GHSA-3m36-mjwj-352c drupal/core (Packagist) Fixed in 9.0.12 Advisory →
- Fix · GHSA-3m36-mjwj-352c drupal/core (Packagist) Fixed in 9.1.7 Advisory →
- Fix · GHSA-3m36-mjwj-352c drupal/drupal (Packagist) Fixed in 7.80 Advisory →
- Fix · GHSA-3m36-mjwj-352c drupal/drupal (Packagist) Fixed in 8.9.14 Advisory →
- Fix · GHSA-3m36-mjwj-352c drupal/drupal (Packagist) Fixed in 9.0.12 Advisory →
- Fix · GHSA-3m36-mjwj-352c drupal/drupal (Packagist) Fixed in 9.1.7 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2020-13672
- 2026-10-03 Alias added: GHSA-3m36-mjwj-352c
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2020-13672 · CVE Program
- CVE-2020-13672 · NVD
- FIRST EPSS
- GHSA-3m36-mjwj-352c · GitHub Advisory Database · CC BY 4.0
- CVE-2020-13672 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences