Read the docs
TI-2020-10734 Aliases CVE-2020-13674GHSA-j586-cj67-vg4p

Cross-site request forgery in Drupal Core

Priority LOW 29CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

The QuickEdit module does not properly validate access to routes, which could allow cross-site request forgery under some circumstances and lead to possible data integrity issues. Sites are only affected if the QuickEdit module (which comes with the Standard profile) is installed. Removing the "access in-place editing" permission from untrusted users will not fully mitigate the vulnerability.

Why it matters now

EPSS 0.00456 39th percentileScored 2026-11-07
Fix Fixed Core (Drupal): 9.2.6, 9.1.13, 8.9.19drupal/core (Packagist): 8.9.19, 9.1.13, 9.2.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalCore9.2 to before 9.2.6; 9.1 to before 9.1.13; 8.9 to before 8.9.199.2.6, 9.1.13, 8.9.19Patch availableCNA
—drupal/core (Packagist)8.0.0 to before 8.9.198.9.19Patch availableGHSA-j586-cj67-vg4p
—drupal/core (Packagist)9.1.0 to before 9.1.139.1.13Patch availableGHSA-j586-cj67-vg4p
—drupal/core (Packagist)9.2.0 to before 9.2.69.2.6Patch availableGHSA-j586-cj67-vg4p
  • Core VendorDrupal Affected 9.2 to before 9.2.6; 9.1 to before 9.1.13; 8.9 to before 8.9.19 Fixed in 9.2.6, 9.1.13, 8.9.19 Patch available CNA
  • drupal/core (Packagist) Vendor— Affected 8.0.0 to before 8.9.19 Fixed in 8.9.19 Patch available GHSA-j586-cj67-vg4p
  • drupal/core (Packagist) Vendor— Affected 9.1.0 to before 9.1.13 Fixed in 9.1.13 Patch available GHSA-j586-cj67-vg4p
  • drupal/core (Packagist) Vendor— Affected 9.2.0 to before 9.2.6 Fixed in 9.2.6 Patch available GHSA-j586-cj67-vg4p

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*8.9.0 to before 8.9.19; 9.1.0 to before 9.1.13; 9.2.0 to before 9.2.6VulnerableDrupal
  • cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.9.0 to before 8.9.19; 9.1.0 to before 9.1.13; 9.2.0 to before 9.2.6 Vulnerable ·Drupal

Remediation

  • Fix · CNA Core (Drupal) Fixed in 9.2.6, 9.1.13, 8.9.19
  • Fix · GHSA-j586-cj67-vg4p drupal/core (Packagist) Fixed in 8.9.19 Advisory →
  • Fix · GHSA-j586-cj67-vg4p drupal/core (Packagist) Fixed in 9.1.13 Advisory →
  • Fix · GHSA-j586-cj67-vg4p drupal/core (Packagist) Fixed in 9.2.6 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Drupal Core 8.9.19, 9.1.13, 9.2.6

    4 records Highest priority Priority MEDIUM 1 MEDIUM, 3 LOW

    Other records, highest priority first

    • TI-2020-10735 Improper access control in Drupal CorePriority MEDIUM 45
    • TI-2020-10737 Improper access control in Drupal CorePriority LOW 35
    • TI-2020-10736 Improper access control in Drupal CorePriority LOW 30

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-13674
  2. 2026-10-03 Alias added: GHSA-j586-cj67-vg4p

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 278 →

Sources