Read the docs
TI-2020-13238 Aliases CVE-2020-17480GHSA-27gm-ghr9-4v95

TinyMCE before 4.9.7 and 5.x before 5.1.4 allows XSS in the core parser, the paste…

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

TinyMCE before 4.9.7 and 5.x before 5.1.4 allows XSS in the core parser, the paste plugin, and the visualchars plugin by using the clipboard or APIs to insert content into the editor.

Why it matters now

EPSS 0.01248 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tinymce (npm): 4.9.7, 5.1.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—tinymce (npm)before 4.9.74.9.7Patch availableGHSA-27gm-ghr9-4v95
—tinymce (npm)5.0.0 to before 5.1.45.1.4Patch availableGHSA-27gm-ghr9-4v95
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • tinymce (npm) Vendor— Affected before 4.9.7 Fixed in 4.9.7 Patch available GHSA-27gm-ghr9-4v95
  • tinymce (npm) Vendor— Affected 5.0.0 to before 5.1.4 Fixed in 5.1.4 Patch available GHSA-27gm-ghr9-4v95

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:*before 4.9.7; 5.0.0 to before 5.1.4VulnerableTiny
  • cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:* Versions before 4.9.7; 5.0.0 to before 5.1.4 Vulnerable ·Tiny

Remediation

  • Fix · GHSA-27gm-ghr9-4v95 tinymce (npm) Fixed in 4.9.7 Advisory →
  • Fix · GHSA-27gm-ghr9-4v95 tinymce (npm) Fixed in 5.1.4 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2020-17480
  2. 2026-10-03 Alias added: GHSA-27gm-ghr9-4v95

References

  • TI-2026-35259 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments CVSS 3.1HIGH 8.7
  • TI-2026-35258 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection CVSS 3.1HIGH 8.7
  • TI-2026-35256 TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes CVSS 3.1HIGH 8.7
  • TI-2026-35257 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs CVSS 3.1HIGH 8.7
  • TI-2024-14570 Cross-site scripting vulnerability in TinyMCE plugins CVSS 3.1MEDIUM 6.1
  • TI-2020-10058 A cross-site scripting (XSS) vulnerability in TinyMCE 5.2.1 and earlier allows remote… CVSS 3.1MEDIUM 6.1
See all 15 →

Sources