Cross-site scripting vulnerability in TinyMCE plugins
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
TinyMCE versions before 5.10.0 are affected by a cross-site scripting vulnerability. A remote and unauthenticated attacker could introduce crafted image or link URLs that would result in the execution of arbitrary JavaScript in an editing user's browser.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00956 61st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed TinyMCE: 5.10.0tinymce (npm): 5.10.0+3 more products
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | TinyMCE | before 5.10.0 | 5.10.0 | Patch available | CNA |
| — | tinymce (npm) | before 5.10.0 | 5.10.0 | Patch available | GHSA-r8hm-w5f7-wj39 |
| — | tinymce/tinymce (Packagist) | before 5.10.0 | 5.10.0 | Patch available | GHSA-r8hm-w5f7-wj39 |
| — | TinyMCE (NuGet) | before 5.10.0 | 5.10.0 | Patch available | GHSA-r8hm-w5f7-wj39 |
| — | django-tinymce (PyPI) | before 3.4.0 | 3.4.0 | Patch available | GHSA-r8hm-w5f7-wj39 |
- TinyMCE Vendor— Affected before 5.10.0 Fixed in 5.10.0 Patch available CNA
- tinymce (npm) Vendor— Affected before 5.10.0 Fixed in 5.10.0 Patch available GHSA-r8hm-w5f7-wj39
- tinymce/tinymce (Packagist) Vendor— Affected before 5.10.0 Fixed in 5.10.0 Patch available GHSA-r8hm-w5f7-wj39
- TinyMCE (NuGet) Vendor— Affected before 5.10.0 Fixed in 5.10.0 Patch available GHSA-r8hm-w5f7-wj39
- django-tinymce (PyPI) Vendor— Affected before 3.4.0 Fixed in 3.4.0 Patch available GHSA-r8hm-w5f7-wj39
Remediation
- Fix · CNA TinyMCE Fixed in 5.10.0
- Fix · GHSA-r8hm-w5f7-wj39 tinymce (npm) Fixed in 5.10.0 Advisory →
- Fix · GHSA-r8hm-w5f7-wj39 tinymce/tinymce (Packagist) Fixed in 5.10.0 Advisory →
- Fix · GHSA-r8hm-w5f7-wj39 TinyMCE (NuGet) Fixed in 5.10.0 Advisory →
- Fix · GHSA-r8hm-w5f7-wj39 django-tinymce (PyPI) Fixed in 3.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-21910
- 2026-10-03 Alias added: GHSA-r8hm-w5f7-wj39
References
Advisory 2
More Tinymce vulnerabilities
- TI-2026-35259 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments CVSS 3.1HIGH 8.7
- TI-2026-35258 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection CVSS 3.1HIGH 8.7
- TI-2026-35256 TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes CVSS 3.1HIGH 8.7
- TI-2026-35257 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs CVSS 3.1HIGH 8.7
- TI-2020-10058 A cross-site scripting (XSS) vulnerability in TinyMCE 5.2.1 and earlier allows remote… CVSS 3.1MEDIUM 6.1
- TI-2019-15973 Cross-site scripting in tinymce CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-21910 · CVE Program
- CVE-2024-21910 · NVD
- FIRST EPSS
- GHSA-r8hm-w5f7-wj39 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences