Read the docs
TI-2021-06987 Aliases CVE-2021-24705GHSA-5w27-mg8j-wjm2

NEX-Forms < 8.4.3 - Stored Cross-Site Scripting via CSRF

Priority LOW 22Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

The NEX-Forms WordPress plugin before 8.4.3 does not have CSRF checks in place when editing a form, and does not escape some of its settings as well as form fields before outputting them in attributes. This could allow attackers to make a logged in admin edit arbitrary forms with Cross-Site Scripting payloads in them

Why it matters now

EPSS 0.00315 24th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed NEX-Forms (Unknown): 8.4.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownNEX-Formsbefore 8.4.38.4.3Patch availableCNA
  • NEX-Forms VendorUnknown Affected before 8.4.3 Fixed in 8.4.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:basixonline:nex-forms:*:*:*:*:*:wordpress:*:*up to 7.9.4Vulnerablewebaways
  • cpe:2.3:a:basixonline:nex-forms:*:*:*:*:*:wordpress:*:* Versions up to 7.9.4 Vulnerable ·webaways

Remediation

  • Fix · CNA NEX-Forms (Unknown) Fixed in 8.4.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24705
  2. 2026-10-03 Alias added: GHSA-5w27-mg8j-wjm2

References

  • TI-2023-01989 NEX-Forms < 8.4 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
  • TI-2023-00416 NEX-Forms < 8.4.4 - Authenticated Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2023-00257 NEX-Forms < 8.3.3 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2022-02901 NEX-Forms < 7.9.7 - Authenticated SQLi CVSS 3.1HIGH 8.8
  • TI-2015-07829 The nex-forms-express-wp-form-builder plugin before 4.6.1 for WordPress has SQL injection… CVSS 3.1CRITICAL 9.8
  • TI-2023-28559 WordPress NEX-Forms – Ultimate Form Builder Plugin <= 8.5.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
See all 20 →

Sources