Read the docs
TI-2022-01618 Aliases CVE-2022-1752GHSA-936g-2f5c-q2w8

Unrestricted Upload of File with Dangerous Type in polonel/trudesk

Priority LOW 39CWE-434Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-434.

Summary

Unrestricted Upload of File with Dangerous Type in GitHub repository polonel/trudesk prior to 1.2.2.

Why it matters now

EPSS 0.01934 80th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed polonel/trudesk (polonel): 1.2.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
polonelpolonel/trudeskbefore 1.2.21.2.2Patch availableCNA
  • polonel/trudesk Vendorpolonel Affected before 1.2.2 Fixed in 1.2.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:trudesk_project:trudesk:*:*:*:*:*:*:*:*before 1.2.2Vulnerablepolonel
  • cpe:2.3:a:trudesk_project:trudesk:*:*:*:*:*:*:*:* Versions before 1.2.2 Vulnerable ·polonel

Remediation

  • Fix · CNA polonel/trudesk (polonel) Fixed in 1.2.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1752
  2. 2026-10-03 Alias added: GHSA-936g-2f5c-q2w8

References

  • TI-2026-78782 Username enumeration via regex injection in Trudesk login CVSS 4.0MEDIUM 6.9
  • TI-2026-78773 Authorization bypass in Trudesk ticket API lets users read other tickets CVSS 4.0MEDIUM 6.9
  • TI-2026-78781 Trudesk Missing Authentication for Ticket Attachments via /uploads CVSS 4.0HIGH 8.2
  • TI-2026-78778 Missing authentication on Trudesk debug routes enables data deletion CVSS 4.0HIGH 8.3
  • TI-2026-78777 MongoDB $where injection in Trudesk ticket search API CVSS 4.0HIGH 7.1
  • TI-2021-20836 TruDesk Help Desk/Ticketing Solution v1.1.11 is vulnerable to a Cross-Site Request… CVSS 3.1MEDIUM 6.5
See all 30 →

Sources