Read the docs

polonel

Records32All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical3CVSS 9.0–10.0
CVSS high9CVSS 7.0–8.9

Exploited now

polonel records in CISA KEV

No polonel vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

32 records

Priority HIGH 70

Trudesk through 1.2.11 contains a regular expression injection vulnerability that allows unauthenticated attackers to enumerate usernames by submitting regex patterns to POST /api/v1/login.

CVSS 4.0MEDIUM 6.9 Network No auth No interaction EPSS 0.00441 Published 2026-10-21 No fix listed CWE-943
Priority HIGH 70

Trudesk through 1.2.11 contains an authorization bypass vulnerability that allows authenticated users to read tickets outside their groups via GET /api/v1/tickets/:uid.

CVSS 4.0MEDIUM 6.9 Network No auth No interaction EPSS 0.00436 Published 2026-10-21 No fix listed CWE-639
Priority HIGH 69

Trudesk through 1.2.11 contains a missing authentication vulnerability that allows unauthenticated attackers to download private ticket attachments under /uploads.

CVSS 4.0HIGH 8.2 Network No auth No interaction EPSS 0.00499 Published 2026-10-21 No fix listed CWE-552
Priority HIGH 69

Trudesk through 1.2.11 contains a missing authentication vulnerability in debug routes enabled whenever NODE_ENV is unset, letting unauthenticated attackers invoke them remotely.

CVSS 4.0HIGH 8.3 Network No auth No interaction EPSS 0.00626 Published 2026-10-21 No fix listed CWE-1188
Priority MEDIUM 64

Trudesk through 1.2.11 contains a server-side JavaScript injection vulnerability that allows authenticated users to inject code into a MongoDB $where clause via the search parameter.

CVSS 4.0HIGH 7.1 Network Low privileges No interaction EPSS 0.00503 Published 2026-10-21 No fix listed CWE-943
Priority MEDIUM 57

Trudesk through 1.2.11 contains a path traversal and authorization bypass vulnerability in accountsController.uploadImage that allows authenticated users to overwrite other users' avatars via form-supplied _id and userna…

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00432 Published 2026-10-21 No fix listed CWE-22
Priority MEDIUM 57

Trudesk through 1.2.11 contains an authorization bypass vulnerability in apiMessages.send that allows authenticated users to post messages as other users due to an incomplete CVE-2022-1931 fix.

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00315 Published 2026-10-21 No fix listed CWE-639
Priority MEDIUM 57

Trudesk through 1.2.11 contains an authorization bypass vulnerability that allows any authenticated user to modify tickets outside their groups via PUT /api/v1/tickets/:id and PUT /api/v2/tickets/batch.

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00315 Published 2026-10-21 No fix listed CWE-639
Priority MEDIUM 48

Incorrect Use of Privileged APIs in GitHub repository polonel/trudesk prior to 1.2.4.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.03203 Published 2022-06-20 Fixed in 1.2.4 CWE-648
Priority MEDIUM 46

Weak Password Requirements in GitHub repository polonel/trudesk prior to 1.2.2.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.02238 Published 2022-05-20 Fixed in 1.2.2 CWE-521
Priority MEDIUM 43

Improper Privilege Management in GitHub repository polonel/trudesk prior to 1.2.2.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.02556 Published 2022-05-20 Fixed in 1.2.2 CWE-269
Priority LOW 39

Incorrect Synchronization in GitHub repository polonel/trudesk prior to 1.2.3.

CVSS 3.1HIGH 8.1 Network Low privileges No interaction EPSS 0.01746 Published 2022-05-31 Fixed in 1.2.3 CWE-821
TI-2022-01584 CVE-2022-1718 · GHSA-733x-qm55-w9g4

Integer overflow in polonel/trudesk

Priority LOW 35

The trudesk application allows large characters to insert in the input field "Full Name" on the signup field which can allow attackers to cause a Denial of Service (DoS) via a crafted HTTP request in GitHub repository po…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01053 Published 2022-05-16 Fixed in 1.2.2 CWE-190
Priority LOW 32

Trudesk through 1.2.11 contains a path traversal vulnerability that allows administrators to delete arbitrary files by supplying encoded traversal sequences to DELETE /api/v1/backup/:backup.

CVSS 4.0HIGH 7.0 Network High privileges No interaction EPSS 0.00592 Published 2026-10-21 No fix listed CWE-22
Priority LOW 31

Use of Incorrect Operator in GitHub repository polonel/trudesk prior to 1.2.3.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.01257 Published 2022-05-31 Fixed in 1.2.3 CWE-480
Priority LOW 31

Integer Overflow or Wraparound in GitHub repository polonel/trudesk prior to 1.2.2.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.01044 Published 2022-05-20 Fixed in 1.2.2 CWE-190
Load more
Open these records in search →