Brizy Page Builder < 2.4.2 - Contributor+ Stored Cross-Site Scripting via Element URL
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Brizy WordPress plugin before 2.4.2 does not sanitise and escape some element URL, which could allow users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks
Why it matters now
EPSS 0.00675 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Brizy – Page Builder (Unknown): 2.4.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Brizy – Page Builder | 2.4.2 to before 2.4.2 | 2.4.2 | Patch available | CNA |
- Brizy – Page Builder VendorUnknown Affected 2.4.2 to before 2.4.2 Fixed in 2.4.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:brizy:brizy:*:*:*:*:*:wordpress:*:* | before 2.4.2 | Vulnerable | themefusecom |
- cpe:2.3:a:brizy:brizy:*:*:*:*:*:wordpress:*:* Versions before 2.4.2 Vulnerable ·themefusecom
Remediation
- Fix · CNA Brizy – Page Builder (Unknown) Fixed in 2.4.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Brizy – Page Builder 2.4.2
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-01891 Brizy Page Builder < 2.4.2 - Contributor+ Stored Cross-Site Scripting via Element ContentPriority LOW 26
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2040
- 2026-10-03 Alias added: GHSA-8695-qgww-9hwp
References
More themefusecom Brizy vulnerabilities
- TI-2024-10159 Brizy – Page Builder <= 2.6.4 - Authenticated (Contributor+) Arbitrary File Upload via storeUploads CVSS 3.1CRITICAL 9.9
- TI-2024-01221 Brizy – Page Builder <= 2.4.40 - Authenticated (Contributor+) Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2024-03040 Brizy – Page Builder <= 2.4.44 - Authenticated (Contributor+) Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2025-19772 WordPress Brizy Pro plugin <= 2.6.1 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-01943 Brizy – Page Builder <= 2.4.43 - Unauthenticated Stored Cross-Site Scripting via Form CVSS 3.1HIGH 7.2
- TI-2025-19773 WordPress Brizy Pro plugin <= 2.6.1 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2022-2040 · CVE Program
- CVE-2022-2040 · NVD
- FIRST EPSS
- GHSA-8695-qgww-9hwp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences