Brizy – Page Builder <= 2.4.44 - Authenticated (Contributor+) Arbitrary File Upload
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.
Summary
The Brizy – Page Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing file extension validation in the validateImageContent function called via storeImages in all versions up to, and including, 2.4.43. This makes it possible for authenticated attackers, with contributor access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. Version 2.4.44 prevents the upload of files ending in .sh and .php. Version 2.4.45 fully patches the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| themefusecom | Brizy – Page Builder | up to 2.4.44 | — | No fix listed | CNA |
- Brizy – Page Builder Vendorthemefusecom Affected up to 2.4.44 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:brizy:brizy:*:*:*:*:*:wordpress:*:* | before 2.4.45 | Vulnerable | themefusecom |
- cpe:2.3:a:brizy:brizy:*:*:*:*:*:wordpress:*:* Versions before 2.4.45 Vulnerable ·themefusecom
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3242
- 2026-10-03 Alias added: GHSA-w8fj-xvmx-vq79
References
Patch 4
- https://plugins.trac.wordpress.org/browser/brizy/trunk/editor/zip/archiver.php#L264
- https://plugins.trac.wordpress.org/browser/brizy/trunk/editor/zip/archiver.php#L547
- https://plugins.trac.wordpress.org/changeset/3086506/brizy/trunk/editor/zip/archiver.php
- https://plugins.trac.wordpress.org/changeset/3112878/brizy/trunk?contextall=1&old=3086506&old_path=%2Fbrizy%2Ftrunk
More themefusecom Brizy vulnerabilities
- TI-2024-10159 Brizy – Page Builder <= 2.6.4 - Authenticated (Contributor+) Arbitrary File Upload via storeUploads CVSS 3.1CRITICAL 9.9
- TI-2024-01221 Brizy – Page Builder <= 2.4.40 - Authenticated (Contributor+) Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2025-19772 WordPress Brizy Pro plugin <= 2.6.1 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-01943 Brizy – Page Builder <= 2.4.43 - Unauthenticated Stored Cross-Site Scripting via Form CVSS 3.1HIGH 7.2
- TI-2025-19773 WordPress Brizy Pro plugin <= 2.6.1 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2020-18885 Brizy < 1.0.126 - Authorization Bypass to Settings Updates CVSS 3.1HIGH 8.1
Sources
- CVE-2024-3242 · CVE Program
- CVE-2024-3242 · NVD
- FIRST EPSS
- GHSA-w8fj-xvmx-vq79 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences