Brizy – Page Builder <= 2.4.43 - Unauthenticated Stored Cross-Site Scripting via Form
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Brizy – Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the form name values in all versions up to, and including, 2.4.43 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| themefusecom | Brizy – Page Builder | up to 2.4.43 | — | No fix listed | CNA |
- Brizy – Page Builder Vendorthemefusecom Affected up to 2.4.43 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:brizy:brizy:*:*:*:*:*:wordpress:*:* | before 2.4.44 | Vulnerable | themefusecom |
- cpe:2.3:a:brizy:brizy:*:*:*:*:*:wordpress:*:* Versions before 2.4.44 Vulnerable ·themefusecom
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2087
- 2026-10-03 Alias added: GHSA-5cfq-mh36-cvhr
References
More themefusecom Brizy vulnerabilities
- TI-2024-10159 Brizy – Page Builder <= 2.6.4 - Authenticated (Contributor+) Arbitrary File Upload via storeUploads CVSS 3.1CRITICAL 9.9
- TI-2024-01221 Brizy – Page Builder <= 2.4.40 - Authenticated (Contributor+) Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2024-03040 Brizy – Page Builder <= 2.4.44 - Authenticated (Contributor+) Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2025-19772 WordPress Brizy Pro plugin <= 2.6.1 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2025-19773 WordPress Brizy Pro plugin <= 2.6.1 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2020-18885 Brizy < 1.0.126 - Authorization Bypass to Settings Updates CVSS 3.1HIGH 8.1
Sources
- CVE-2024-2087 · CVE Program
- CVE-2024-2087 · NVD
- FIRST EPSS
- GHSA-5cfq-mh36-cvhr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences