Brizy – Page Builder <= 2.6.4 - Authenticated (Contributor+) Arbitrary File Upload via storeUploads
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.
Summary
The Brizy – Page Builder plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'storeUploads' function in all versions up to, and including, 2.6.4. This makes it possible for authenticated attackers, with Contributor-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| themefusecom | Brizy – Page Builder | up to 2.6.4 | — | No fix listed | CNA |
- Brizy – Page Builder Vendorthemefusecom Affected up to 2.6.4 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:brizy:brizy:*:*:*:*:*:wordpress:*:* | before 2.6.5 | Vulnerable | themefusecom |
- cpe:2.3:a:brizy:brizy:*:*:*:*:*:wordpress:*:* Versions before 2.6.5 Vulnerable ·themefusecom
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10960
- 2026-10-03 Alias added: GHSA-g6m2-22qr-9mgq
References
More themefusecom Brizy vulnerabilities
- TI-2024-01221 Brizy – Page Builder <= 2.4.40 - Authenticated (Contributor+) Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2024-03040 Brizy – Page Builder <= 2.4.44 - Authenticated (Contributor+) Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2025-19772 WordPress Brizy Pro plugin <= 2.6.1 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
- TI-2024-01943 Brizy – Page Builder <= 2.4.43 - Unauthenticated Stored Cross-Site Scripting via Form CVSS 3.1HIGH 7.2
- TI-2025-19773 WordPress Brizy Pro plugin <= 2.6.1 - Cross Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2020-18885 Brizy < 1.0.126 - Authorization Bypass to Settings Updates CVSS 3.1HIGH 8.1
Sources
- CVE-2024-10960 · CVE Program
- CVE-2024-10960 · NVD
- FIRST EPSS
- GHSA-g6m2-22qr-9mgq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences