Post SMTP < 2.1.7 - Admin+ Blind SSRF
Priority HIGH 65CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Post SMTP Mailer/Email Log WordPress plugin before 2.1.7 does not have proper authorisation in some AJAX actions, which could allow high privilege users such as admin to perform blind SSRF on multisite installations for example.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01376 72nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Post SMTP Mailer/Email Log (Unknown): 2.1.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Post SMTP Mailer/Email Log | 2.1.7 to before 2.1.7 | 2.1.7 | Patch available | CNA |
- Post SMTP Mailer/Email Log VendorUnknown Affected 2.1.7 to before 2.1.7 Fixed in 2.1.7 Patch available CNA
Remediation
- Fix · CNA Post SMTP Mailer/Email Log (Unknown) Fixed in 2.1.7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-2352
- 2026-10-03 Alias added: GHSA-6g4h-jgh3-vxwj
References
More WPExperts Post Smtp vulnerabilities
- TI-2023-06280 Authorization bypass in saadiqbal Post SMTP – Complete Email Deliverability and SMTP… CVSS 3.1CRITICAL 9.8
- TI-2023-02978 POST SMTP Mailer < 2.5.7 - Account Takeover via CSRF CVSS 3.1HIGH 8.8
- TI-2023-06067 Post SMTP < 2.8.7 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2023-06068 Post SMTP < 2.8.7 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-02977 POST SMTP Mailer < 2.5.7 - Arbitrary Log Deletion via CSRF CVSS 3.1MEDIUM 4.3
- TI-2023-28661 WordPress POST SMTP Mailer plugin <= 2.8.6 - Broken Access Control on API vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-2352 · CVE Program
- CVE-2022-2352 · NVD
- FIRST EPSS
- GHSA-6g4h-jgh3-vxwj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences