Priority CRITICAL 92
The POST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress plugin for WordPress is vulnerable to unauthorized access of data and modification of data due to a type juggling issue on…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.90339 · Published 2024-01-11 · No fix listed CWE-639
Priority HIGH 73
The POST SMTP Mailer WordPress plugin before 2.5.7 does not have proper CSRF checks in some AJAX actions, which could allow attackers to make logged in users with the manage_postman_smtp capability resend an email to an…
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00389 · Published 2023-07-17 · Fixed in 2.5.7 CWE-352
Priority HIGH 65
The POST SMTP Mailer WordPress plugin before 2.8.7 does not properly sanitise and escape several parameters before using them in SQL statements, leading to a SQL injection exploitable by high privilege users such as admi…
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.14057 · Published 2024-01-15 · Fixed in 2.8.7 CWE-89
Priority HIGH 65
The Post SMTP Mailer/Email Log WordPress plugin before 2.1.7 does not have proper authorisation in some AJAX actions, which could allow high privilege users such as admin to perform blind SSRF on multisite installations…
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.01376 · Published 2022-09-26 · Fixed in 2.1.7 CWE-918
Priority MEDIUM 60
The POST SMTP WordPress plugin before 2.8.7 does not sanitise and escape the msg parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege use…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00401 · Published 2024-01-03 · Fixed in 2.8.7 CWE-79
Priority MEDIUM 53
The POST SMTP Mailer WordPress plugin before 2.5.7 does not have proper CSRF checks in some AJAX actions, which could allow attackers to make logged in users with the manage_postman_smtp capability delete arbitrary logs…
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00266 · Published 2024-01-16 · Fixed in 2.5.7 CWE-352
Priority MEDIUM 48
Missing Authorization vulnerability in Post SMTP Post SMTP Mailer/Email Log.This issue affects Post SMTP Mailer/Email Log: from n/a through 2.8.6.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00367 · Published 2024-06-11 · No fix listed CWE-862
Priority LOW 39
The POST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘device’ header in all versions up to, and inclu…
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.00941 · Published 2024-01-03 · No fix listed CWE-79
Priority LOW 38
Missing Authorization vulnerability in Saad Iqbal Post SMTP post-smtp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Post SMTP: from n/a through <= 2.9.11.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00396 · Published 2025-01-13 · No fix listed CWE-862
Priority LOW 38
The Post SMTP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the from and subject parameter in all versions up to, and including, 3.0.2 due to insufficient input sanitization and output escaping.
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.00325 · Published 2025-02-18 · No fix listed CWE-79
Priority LOW 38
The Post SMTP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via email contents in versions up to, and including, 2.5.7 due to insufficient input sanitization and output escaping.
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.00496 · Published 2023-07-12 · No fix listed CWE-79
Priority LOW 34
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Saad Iqbal Post SMTP post-smtp allows Blind SQL Injection.This issue affects Post SMTP: from n/a through <= 2.9.9.
CVSS 3.1HIGH 7.6· Network · High privileges · No interaction · EPSS 0.00465 · Published 2024-11-18 · No fix listed CWE-89
Priority LOW 32
The POST SMTP – The #1 WordPress SMTP Plugin with Advanced Email Logging and Delivery Failure Notifications plugin for WordPress is vulnerable to time-based SQL Injection via the selected parameter in all versions up to,…
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.00495 · Published 2024-05-30 · No fix listed CWE-89
Priority LOW 31
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Post SMTP POST SMTP allows Reflected XSS.This issue affects POST SMTP: from n/a through 2.8.6.
CVSS 3.1HIGH 7.1· Network · No auth · User interaction · EPSS 0.00382 · Published 2024-03-19 · No fix listed CWE-79
Priority LOW 28
The POST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘msg’ parameter in all versions up to, and in…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00442 · Published 2024-01-03 · No fix listed CWE-79
Priority LOW 28
The POST SMTP Mailer WordPress plugin before 2.7.1 does not escape email message content before displaying it in the backend, allowing an unauthenticated attacker to perform XSS attacks against highly privileged users.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.0051 · Published 2023-11-27 · Fixed in 2.7.1 CWE-79
Priority LOW 25
The Post SMTP plugin for WordPress is vulnerable to generic SQL Injection via the ‘columns’ parameter in all versions up to, and including, 3.1.2 due to insufficient escaping on the user supplied parameter and lack of su…
CVSS 3.1MEDIUM 4.9· Network · High privileges · No interaction · EPSS 0.00399 · Published 2025-03-08 · No fix listed CWE-89
Priority LOW 23
The Post SMTP Mailer/Email Log WordPress plugin before 2.1.4 does not escape some of its settings before outputting them in the admins dashboard, allowing high privilege users to perform Cross-Site Scripting attacks agai…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00677 · Published 2022-09-16 · Fixed in 2.1.4 CWE-79
Priority LOW 21
The POST SMTP Mailer plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.0.20.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00541 · Published 2023-07-12 · No fix listed CWE-352