Post SMTP < 2.8.7 - Reflected Cross-Site Scripting
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The POST SMTP WordPress plugin before 2.8.7 does not sanitise and escape the msg parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00401 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed POST SMTP (Unknown): 2.8.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | POST SMTP | before 2.8.7 | 2.8.7 | Patch available | CNA |
- POST SMTP VendorUnknown Affected before 2.8.7 Fixed in 2.8.7 Patch available CNA
Remediation
- Fix · CNA POST SMTP (Unknown) Fixed in 2.8.7
Timeline
- 2026-10-02 Threatist record created from CVE-2023-6621
- 2026-10-03 Alias added: GHSA-gr9g-7x3w-8vjj
References
More WPExperts Post Smtp vulnerabilities
- TI-2023-06280 Authorization bypass in saadiqbal Post SMTP – Complete Email Deliverability and SMTP… CVSS 3.1CRITICAL 9.8
- TI-2023-02978 POST SMTP Mailer < 2.5.7 - Account Takeover via CSRF CVSS 3.1HIGH 8.8
- TI-2023-06067 Post SMTP < 2.8.7 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2022-02171 Post SMTP < 2.1.7 - Admin+ Blind SSRF CVSS 3.1HIGH 7.2
- TI-2023-02977 POST SMTP Mailer < 2.5.7 - Arbitrary Log Deletion via CSRF CVSS 3.1MEDIUM 4.3
- TI-2023-28661 WordPress POST SMTP Mailer plugin <= 2.8.6 - Broken Access Control on API vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-6621 · CVE Program
- CVE-2023-6621 · NVD
- FIRST EPSS
- GHSA-gr9g-7x3w-8vjj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences