POST SMTP Mailer < 2.5.7 - Account Takeover via CSRF
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
The POST SMTP Mailer WordPress plugin before 2.5.7 does not have proper CSRF checks in some AJAX actions, which could allow attackers to make logged in users with the manage_postman_smtp capability resend an email to an arbitrary address (for example a password reset email could be resent to an attacker controlled email, and allow them to take over an account).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | POST SMTP Mailer | 2.5.0 to before 2.5.7 | 2.5.7 | Patch available | CNA |
- POST SMTP Mailer VendorUnknown Affected 2.5.0 to before 2.5.7 Fixed in 2.5.7 Patch available CNA
Remediation
- Fix · CNA POST SMTP Mailer (Unknown) Fixed in 2.5.7
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3179
- 2026-10-03 Alias added: GHSA-6qcm-jr9r-5m65
References
More WPExperts Post Smtp vulnerabilities
- TI-2023-06280 Authorization bypass in saadiqbal Post SMTP – Complete Email Deliverability and SMTP… CVSS 3.1CRITICAL 9.8
- TI-2023-06067 Post SMTP < 2.8.7 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2022-02171 Post SMTP < 2.1.7 - Admin+ Blind SSRF CVSS 3.1HIGH 7.2
- TI-2023-06068 Post SMTP < 2.8.7 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-02977 POST SMTP Mailer < 2.5.7 - Arbitrary Log Deletion via CSRF CVSS 3.1MEDIUM 4.3
- TI-2023-28661 WordPress POST SMTP Mailer plugin <= 2.8.6 - Broken Access Control on API vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-3179 · CVE Program
- CVE-2023-3179 · NVD
- FIRST EPSS
- GHSA-6qcm-jr9r-5m65 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences