POST SMTP Mailer < 2.5.7 - Arbitrary Log Deletion via CSRF
Priority MEDIUM 53CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
The POST SMTP Mailer WordPress plugin before 2.5.7 does not have proper CSRF checks in some AJAX actions, which could allow attackers to make logged in users with the manage_postman_smtp capability delete arbitrary logs via a CSRF attack.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00266 18th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed POST SMTP Mailer (Unknown): 2.5.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | POST SMTP Mailer | 2.5.0 to before 2.5.7 | 2.5.7 | Patch available | CNA |
- POST SMTP Mailer VendorUnknown Affected 2.5.0 to before 2.5.7 Fixed in 2.5.7 Patch available CNA
Remediation
- Fix · CNA POST SMTP Mailer (Unknown) Fixed in 2.5.7
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3178
- 2026-10-03 Alias added: GHSA-vv37-8w95-rgj3
References
More WPExperts Post Smtp vulnerabilities
- TI-2023-06280 Authorization bypass in saadiqbal Post SMTP – Complete Email Deliverability and SMTP… CVSS 3.1CRITICAL 9.8
- TI-2023-02978 POST SMTP Mailer < 2.5.7 - Account Takeover via CSRF CVSS 3.1HIGH 8.8
- TI-2023-06067 Post SMTP < 2.8.7 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2022-02171 Post SMTP < 2.1.7 - Admin+ Blind SSRF CVSS 3.1HIGH 7.2
- TI-2023-06068 Post SMTP < 2.8.7 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2023-28661 WordPress POST SMTP Mailer plugin <= 2.8.6 - Broken Access Control on API vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-3178 · CVE Program
- CVE-2023-3178 · NVD
- FIRST EPSS
- GHSA-vv37-8w95-rgj3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences