Cross-site scripting vulnerability in TinyMCE alerts
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
tinymce is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in the alert and confirm dialogs when these dialogs were provided with malicious HTML content. This can occur in plugins that use the alert or confirm dialogs, such as in the `image` plugin, which presents these dialogs when certain errors occur. The vulnerability allowed arbitrary JavaScript execution when an alert presented in the TinyMCE UI for the current user. This vulnerability has been patched in TinyMCE 5.10.7 and TinyMCE 6.3.1 by ensuring HTML sanitization was still performed after unwrapping invalid elements. Users are advised to upgrade to either 5.10.7 or 6.3.1. Users unable to upgrade may ensure the the `images_upload_handler` returns a valid value as per the images_upload_handler documentation.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tinymce | tinymce | before 5.10.7; 6.0.0 to before 6.3.1 | 5.10.7, 6.3.1 | Patch available | CNA |
| — | tinymce (npm) | 6.0.0 to before 6.3.1 | 6.3.1 | Patch available | GHSA-gg8r-xjwq-4w92 |
| — | tinymce/tinymce (Packagist) | 6.0.0 to before 6.3.1 | 6.3.1 | Patch available | GHSA-gg8r-xjwq-4w92 |
| — | TinyMCE (NuGet) | 6.0.0 to before 6.3.1 | 6.3.1 | Patch available | GHSA-gg8r-xjwq-4w92 |
| — | tinymce (npm) | before 5.10.7 | 5.10.7 | Patch available | GHSA-gg8r-xjwq-4w92 |
| — | tinymce/tinymce (Packagist) | before 5.10.7 | 5.10.7 | Patch available | GHSA-gg8r-xjwq-4w92 |
| — | TinyMCE (NuGet) | before 5.10.7 | 5.10.7 | Patch available | GHSA-gg8r-xjwq-4w92 |
- tinymce Vendortinymce Affected before 5.10.7; 6.0.0 to before 6.3.1 Fixed in 5.10.7, 6.3.1 Patch available CNA
- tinymce (npm) Vendor— Affected 6.0.0 to before 6.3.1 Fixed in 6.3.1 Patch available GHSA-gg8r-xjwq-4w92
- tinymce/tinymce (Packagist) Vendor— Affected 6.0.0 to before 6.3.1 Fixed in 6.3.1 Patch available GHSA-gg8r-xjwq-4w92
- TinyMCE (NuGet) Vendor— Affected 6.0.0 to before 6.3.1 Fixed in 6.3.1 Patch available GHSA-gg8r-xjwq-4w92
- tinymce (npm) Vendor— Affected before 5.10.7 Fixed in 5.10.7 Patch available GHSA-gg8r-xjwq-4w92
- tinymce/tinymce (Packagist) Vendor— Affected before 5.10.7 Fixed in 5.10.7 Patch available GHSA-gg8r-xjwq-4w92
- TinyMCE (NuGet) Vendor— Affected before 5.10.7 Fixed in 5.10.7 Patch available GHSA-gg8r-xjwq-4w92
Remediation
- Fix · CNA tinymce (tinymce) Fixed in 5.10.7, 6.3.1
- Fix · GHSA-gg8r-xjwq-4w92 tinymce (npm) Fixed in 6.3.1 Advisory →
- Fix · GHSA-gg8r-xjwq-4w92 tinymce/tinymce (Packagist) Fixed in 6.3.1 Advisory →
- Fix · GHSA-gg8r-xjwq-4w92 TinyMCE (NuGet) Fixed in 6.3.1 Advisory →
- Fix · GHSA-gg8r-xjwq-4w92 tinymce (npm) Fixed in 5.10.7 Advisory →
- Fix · GHSA-gg8r-xjwq-4w92 tinymce/tinymce (Packagist) Fixed in 5.10.7 Advisory →
- Fix · GHSA-gg8r-xjwq-4w92 TinyMCE (NuGet) Fixed in 5.10.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23494
- 2026-10-03 Alias added: GHSA-gg8r-xjwq-4w92
References
Patch 3
Advisory 4
More tinymce vulnerabilities
- TI-2011-04153 Static code injection vulnerability in inc/function.base.php in Ajax File and Image… CVSS 2.0HIGH 7.5
- TI-2026-81439 Cross-site scripting in TinyMCE media plugin via data-mce-object CVSS 4.0HIGH 8.5
- TI-2026-35259 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments CVSS 3.1HIGH 8.7
- TI-2026-35258 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection CVSS 3.1HIGH 8.7
- TI-2026-35256 TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes CVSS 3.1HIGH 8.7
- TI-2026-35257 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs CVSS 3.1HIGH 8.7
Sources
- CVE-2022-23494 · CVE Program
- CVE-2022-23494 · NVD
- FIRST EPSS
- GHSA-gg8r-xjwq-4w92 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences