Improper Input Validation in GeoServer
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-917.
Summary
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. The GeoServer security mechanism can perform an unchecked JNDI lookup, which in turn can be used to perform class deserialization and result in arbitrary code execution. The same can happen while configuring data stores with data sources located in JNDI, or while setting up the disk quota mechanism. In order to perform any of the above changes, the attack needs to have obtained admin rights and use either the GeoServer GUI, or its REST API. The lookups are going to be restricted in GeoServer 2.21.0, 2.20.4, 1.19.6. Users unable to upgrade should restrict access to the `geoserver/web` and `geoserver/rest` via a firewall and ensure that the GeoWebCache is not remotely accessible.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| geoserver | geoserver | 2.20.0 to before 2.20.4; before 2.19.6 | 2.20.4, 2.19.6 | Patch available | CNA |
| — | org.geoserver:gs-main (Maven) | 2.20.0 to before 2.20.4 | 2.20.4 | Patch available | GHSA-4pm3-f52j-8ggh |
| — | org.geoserver:gs-main (Maven) | before 2.19.6 | 2.19.6 | Patch available | GHSA-4pm3-f52j-8ggh |
- geoserver Vendorgeoserver Affected 2.20.0 to before 2.20.4; before 2.19.6 Fixed in 2.20.4, 2.19.6 Patch available CNA
- org.geoserver:gs-main (Maven) Vendor— Affected 2.20.0 to before 2.20.4 Fixed in 2.20.4 Patch available GHSA-4pm3-f52j-8ggh
- org.geoserver:gs-main (Maven) Vendor— Affected before 2.19.6 Fixed in 2.19.6 Patch available GHSA-4pm3-f52j-8ggh
Remediation
- Fix · CNA geoserver (geoserver) Fixed in 2.20.4, 2.19.6
- Fix · GHSA-4pm3-f52j-8ggh org.geoserver:gs-main (Maven) Fixed in 2.20.4 Advisory →
- Fix · GHSA-4pm3-f52j-8ggh org.geoserver:gs-main (Maven) Fixed in 2.19.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24847
- 2026-10-03 Alias added: GHSA-4pm3-f52j-8ggh
References
More geoserver vulnerabilities
- TI-2024-24187 Remote Code Execution (RCE) vulnerability in evaluating property name expressions in Geoserver KEVCVSS 3.1CRITICAL 9.8
- TI-2025-36149 GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature KEVCVSS 3.1CRITICAL 9.8
- TI-2023-10619 Unfiltered SQL Injection Vulnerabilities in Geoserver CVSS 3.1CRITICAL 9.8
- TI-2023-23486 WPS Server Side Request Forgery in GeoServer CVSS 3.1CRITICAL 9.8
- TI-2023-17518 GeoServer 2, in some configurations, allows remote attackers to execute arbitrary code… CVSS 3.1CRITICAL 9.8
- TI-2025-21556 GeoTools, GeoServer, and GeoNetwork XML External Entity (XXE) Processing Vulnerability in XSD schema handling CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-24847 · CVE Program
- CVE-2022-24847 · NVD
- FIRST EPSS
- GHSA-4pm3-f52j-8ggh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences