Incorrect authorization in Drupal Core
Priority LOW 30CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
The Quick Edit module does not properly check entity access in some circumstances. This could result in users with the "access in-place editing" permission viewing some content they are are not authorized to access. Sites are only affected if the QuickEdit module (which comes with the Standard profile) is installed.
Why it matters now
EPSS 0.00769 55th percentileScored 2026-11-07
Fix Fixed Core (Drupal): 9.3.6, 9.2.13drupal/core (Packagist): 9.3.6, 9.2.13
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Core | 9.3.x to before 9.3.6; 9.2.x to before 9.2.13 | 9.3.6, 9.2.13 | Patch available | CNA |
| — | drupal/core (Packagist) | 9.3.0 to before 9.3.6 | 9.3.6 | Patch available | GHSA-73q4-j324-2qcc |
| — | drupal/core (Packagist) | 8.0.0 to before 9.2.13 | 9.2.13 | Patch available | GHSA-73q4-j324-2qcc |
- Core VendorDrupal Affected 9.3.x to before 9.3.6; 9.2.x to before 9.2.13 Fixed in 9.3.6, 9.2.13 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 9.3.0 to before 9.3.6 Fixed in 9.3.6 Patch available GHSA-73q4-j324-2qcc
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 9.2.13 Fixed in 9.2.13 Patch available GHSA-73q4-j324-2qcc
Remediation
- Fix · CNA Core (Drupal) Fixed in 9.3.6, 9.2.13
- Fix · GHSA-73q4-j324-2qcc drupal/core (Packagist) Fixed in 9.3.6 Advisory →
- Fix · GHSA-73q4-j324-2qcc drupal/core (Packagist) Fixed in 9.2.13 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25270
- 2026-10-03 Alias added: GHSA-73q4-j324-2qcc
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2022-25270 · CVE Program
- CVE-2022-25270 · NVD
- FIRST EPSS
- GHSA-73q4-j324-2qcc · GitHub Advisory Database · CC BY 4.0
- CVE-2022-25270 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences