Improper input validation in Drupal Core
Priority LOW 35CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Drupal core's form API has a vulnerability where certain contributed or custom modules' forms may be vulnerable to improper input validation. This could allow an attacker to inject disallowed values or overwrite data. Affected forms are uncommon, but in certain cases an attacker could alter critical or sensitive data.
Why it matters now
EPSS 0.01272 70th percentileScored 2026-11-07
Fix Fixed Core (Drupal): 9.3.6, 9.2.13, 7.88drupal/core (Packagist): 9.3.6, 9.2.13, 7.88
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Core | 9.3.x to before 9.3.6; 9.2.x to before 9.2.13; 7.x to before 7.88 | 9.3.6, 9.2.13, 7.88 | Patch available | CNA |
| — | drupal/core (Packagist) | 9.3.0 to before 9.3.6 | 9.3.6 | Patch available | GHSA-fmfv-x8mp-5767 |
| — | drupal/core (Packagist) | 8.0.0 to before 9.2.13 | 9.2.13 | Patch available | GHSA-fmfv-x8mp-5767 |
| — | drupal/core (Packagist) | 7.0.0 to before 7.88 | 7.88 | Patch available | GHSA-fmfv-x8mp-5767 |
- Core VendorDrupal Affected 9.3.x to before 9.3.6; 9.2.x to before 9.2.13; 7.x to before 7.88 Fixed in 9.3.6, 9.2.13, 7.88 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 9.3.0 to before 9.3.6 Fixed in 9.3.6 Patch available GHSA-fmfv-x8mp-5767
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 9.2.13 Fixed in 9.2.13 Patch available GHSA-fmfv-x8mp-5767
- drupal/core (Packagist) Vendor— Affected 7.0.0 to before 7.88 Fixed in 7.88 Patch available GHSA-fmfv-x8mp-5767
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 7.0.0 to before 7.88; 9.2.0 to before 9.2.13; 9.3.0 to before 9.3.6 | Vulnerable | Drupal |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 7.0.0 to before 7.88; 9.2.0 to before 9.2.13; 9.3.0 to before 9.3.6 Vulnerable ·Drupal
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA Core (Drupal) Fixed in 9.3.6, 9.2.13, 7.88
- Fix · GHSA-fmfv-x8mp-5767 drupal/core (Packagist) Fixed in 9.3.6 Advisory →
- Fix · GHSA-fmfv-x8mp-5767 drupal/core (Packagist) Fixed in 9.2.13 Advisory →
- Fix · GHSA-fmfv-x8mp-5767 drupal/core (Packagist) Fixed in 7.88 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25271
- 2026-10-03 Alias added: GHSA-fmfv-x8mp-5767
References
Advisory 3
Other 4
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HVKIOWSXL2RF2ULNAP7PHESYCFSZIJE3
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SGSY236PYSFYIEBRGDERLA7OSY6D7XL4
- https://lists.fedoraproject.org/archives/list/[email protected]/message/HVKIOWSXL2RF2ULNAP7PHESYCFSZIJE3
- https://lists.fedoraproject.org/archives/list/[email protected]/message/SGSY236PYSFYIEBRGDERLA7OSY6D7XL4
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2022-25271 · CVE Program
- CVE-2022-25271 · NVD
- FIRST EPSS
- GHSA-fmfv-x8mp-5767 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-25271 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences