Improper input validation in Drupal Core
Priority MEDIUM 40CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
Drupal core's form API has a vulnerability where certain contributed or custom modules' forms may be vulnerable to improper input validation. This could allow an attacker to inject disallowed values or overwrite data. Affected forms are uncommon, but in certain cases an attacker could alter critical or sensitive data.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00568 47th percentileScored 2026-11-07
Fix Fixed Core (Drupal): 9.3.12, 9.2.18drupal/core (Packagist): 9.2.18, 9.3.12
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Core | 9.3 to before 9.3.12; 9.2 to before 9.2.18 | 9.3.12, 9.2.18 | Patch available | CNA |
| — | drupal/core (Packagist) | 8.0.0 to before 9.2.18 | 9.2.18 | Patch available | GHSA-g36h-4jr6-qmm9 |
| — | drupal/core (Packagist) | 9.3.0 to before 9.3.12 | 9.3.12 | Patch available | GHSA-g36h-4jr6-qmm9 |
- Core VendorDrupal Affected 9.3 to before 9.3.12; 9.2 to before 9.2.18 Fixed in 9.3.12, 9.2.18 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 9.2.18 Fixed in 9.2.18 Patch available GHSA-g36h-4jr6-qmm9
- drupal/core (Packagist) Vendor— Affected 9.3.0 to before 9.3.12 Fixed in 9.3.12 Patch available GHSA-g36h-4jr6-qmm9
Remediation
- Fix · CNA Core (Drupal) Fixed in 9.3.12, 9.2.18
- Fix · GHSA-g36h-4jr6-qmm9 drupal/core (Packagist) Fixed in 9.2.18 Advisory →
- Fix · GHSA-g36h-4jr6-qmm9 drupal/core (Packagist) Fixed in 9.3.12 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25273
- 2026-10-03 Alias added: GHSA-g36h-4jr6-qmm9
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2022-25273 · CVE Program
- CVE-2022-25273 · NVD
- FIRST EPSS
- GHSA-g36h-4jr6-qmm9 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-25273 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences