Read the docs
TI-2022-08983 Aliases CVE-2022-25278GHSA-cfh2-7f6h-3m85

Under certain circumstances, the Drupal core form API evaluates form element access…

Priority LOW 30Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.

Summary

Under certain circumstances, the Drupal core form API evaluates form element access incorrectly. This may lead to a user being able to alter data they should not have access to. No forms provided by Drupal core are known to be vulnerable. However, forms added through contributed or custom modules or themes may be affected.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0059 48th percentileScored 2026-11-07
Fix Fixed Core (Drupal): 9.4.3, 9.3.19drupal/core (Packagist): 9.3.19, 9.4.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalCore9.4 to before 9.4.3; 9.3 to before 9.3.199.4.3, 9.3.19Patch availableCNA
—drupal/core (Packagist)8.0.0 to before 9.3.199.3.19Patch availableGHSA-cfh2-7f6h-3m85
—drupal/core (Packagist)9.4.0 to before 9.4.39.4.3Patch availableGHSA-cfh2-7f6h-3m85
  • Core VendorDrupal Affected 9.4 to before 9.4.3; 9.3 to before 9.3.19 Fixed in 9.4.3, 9.3.19 Patch available CNA
  • drupal/core (Packagist) Vendor— Affected 8.0.0 to before 9.3.19 Fixed in 9.3.19 Patch available GHSA-cfh2-7f6h-3m85
  • drupal/core (Packagist) Vendor— Affected 9.4.0 to before 9.4.3 Fixed in 9.4.3 Patch available GHSA-cfh2-7f6h-3m85

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*8.0.0 to before 9.3.19; 9.4.0 to before 9.4.3VulnerableDrupal
  • cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.0.0 to before 9.3.19; 9.4.0 to before 9.4.3 Vulnerable ·Drupal

Remediation

  • Fix · CNA Core (Drupal) Fixed in 9.4.3, 9.3.19
  • Fix · GHSA-cfh2-7f6h-3m85 drupal/core (Packagist) Fixed in 9.3.19 Advisory →
  • Fix · GHSA-cfh2-7f6h-3m85 drupal/core (Packagist) Fixed in 9.4.3 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Drupal Core 9.3.19, 9.4.3

    3 records Highest priority Priority LOW 3 LOW

    Other records, highest priority first

    • TI-2022-08982 Unrestricted file upload in Drupal CorePriority LOW 37
    • TI-2022-08981 Cross-site scripting in Drupal CorePriority LOW 28

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-25278
  2. 2026-10-03 Alias added: GHSA-cfh2-7f6h-3m85

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 278 →

Sources