Read the docs
TI-2022-09871 Aliases CVE-2022-26533GHSA-jpj5-hg26-6jgc

Alist v2.1.0 and below was discovered to contain a cross-site scripting (XSS) vulnerability via /i/:data/ipa.plist.

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Alist v2.1.0 and below was discovered to contain a cross-site scripting (XSS) vulnerability via /i/:data/ipa.plist.

Why it matters now

EPSS 0.00716 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed github.com/Xhofe/alist (Go): 2.1.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—github.com/Xhofe/alist (Go)2.0.10 to before 2.1.12.1.1Patch availableGHSA-jpj5-hg26-6jgc
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • github.com/Xhofe/alist (Go) Vendor— Affected 2.0.10 to before 2.1.1 Fixed in 2.1.1 Patch available GHSA-jpj5-hg26-6jgc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:alistgo:alist:*:*:*:*:*:*:*:*up to 2.1.0VulnerableAlistGo
  • cpe:2.3:a:alistgo:alist:*:*:*:*:*:*:*:* Versions up to 2.1.0 Vulnerable ·AlistGo

Remediation

  • Fix · GHSA-jpj5-hg26-6jgc github.com/Xhofe/alist (Go) Fixed in 2.1.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-26533
  2. 2026-10-03 Alias added: GHSA-jpj5-hg26-6jgc

References

  • TI-2022-22731 Alist v3.4.0 is vulnerable to Directory Traversal, CVSS 3.1CRITICAL 9.8
  • TI-2022-22730 Alist v3.4.0 is vulnerable to File Upload. CVSS 3.1HIGH 8.8
  • TI-2023-15192 AList 3.15.1 is vulnerable to Incorrect Access Control, which can be exploited by… CVSS 3.1HIGH 7.5
  • TI-2022-22732 Alist v3.5.1 is vulnerable to Cross Site Scripting (XSS) via the bulletin board. CVSS 3.1MEDIUM 5.4
  • TI-2024-31449 Alist Contains a Reflected Cross-Site Scripting Vulnerability CVSS 4.0MEDIUM 5.1
  • TI-2026-20320 Alist has Insecure TLS Config CVSS 3.1CRITICAL 9.1
See all 8 →

Sources