Read the docs
TI-2026-32065 Aliases CVE-2026-44025GHSA-pr7j-96cj-549h

Fluentd: Exposure of Sensitive Information via Monitor Agent API

Priority LOW 39CWE-306Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass, Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-306 and CWE-200.

Summary

Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd's Monitor Agent plugin in_monitor_agent exposes internal metrics and plugin information via a REST API, and responses from /api/plugins.json and related endpoints unintentionally include internal instance variables that may contain database passwords, API keys, or cloud credentials. This issue is fixed in version 1.19.3.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00474 41st percentileScored 2026-11-07
Fix Fixed fluentd (fluent): 1.19.3fluentd (RubyGems): 1.19.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
fluentfluentdbefore 1.19.31.19.3Patch availableCNA
—fluentd (RubyGems)before 1.19.31.19.3Patch availableGHSA-pr7j-96cj-549h
  • fluentd Vendorfluent Affected before 1.19.3 Fixed in 1.19.3 Patch available CNA
  • fluentd (RubyGems) Vendor— Affected before 1.19.3 Fixed in 1.19.3 Patch available GHSA-pr7j-96cj-549h

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:fluentd:fluentd:*:*:*:*:*:*:*:*before 1.19.3Vulnerablefluent
  • cpe:2.3:a:fluentd:fluentd:*:*:*:*:*:*:*:* Versions before 1.19.3 Vulnerable ·fluent

Remediation

  • Fix · CNA fluentd (fluent) Fixed in 1.19.3
  • Fix · GHSA-pr7j-96cj-549h fluentd (RubyGems) Fixed in 1.19.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-44025
  2. 2026-10-03 Alias added: GHSA-pr7j-96cj-549h

References

  • TI-2022-18753 Fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration) CVSS 3.1CRITICAL 9.8
  • TI-2026-32064 Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder CVSS 3.1CRITICAL 9.8
  • TI-2017-07995 Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may… CVSS 3.0CRITICAL 9.8
  • TI-2020-14076 An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated… CVSS 3.1HIGH 8.8
  • TI-2026-32142 Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward` CVSS 3.1HIGH 7.5
  • TI-2026-32143 Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http` CVSS 3.1HIGH 7.2
See all 7 →

Sources