Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, the Fluentd out_http output plugin allows placeholders such as ${tag} in the endpoint configuration parameter, and if a placeholder value is derived from untrusted input an attacker can control the destination hostname of outbound HTTP requests and force requests to arbitrary internal services. This issue is fixed in version 1.19.3.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fluent | fluentd | before 1.19.3 | 1.19.3 | Patch available | CNA |
| — | fluentd (RubyGems) | before 1.19.3 | 1.19.3 | Patch available | GHSA-72f5-rr8c-r6gr |
- fluentd Vendorfluent Affected before 1.19.3 Fixed in 1.19.3 Patch available CNA
- fluentd (RubyGems) Vendor— Affected before 1.19.3 Fixed in 1.19.3 Patch available GHSA-72f5-rr8c-r6gr
Remediation
- Fix · CNA fluentd (fluent) Fixed in 1.19.3
- Fix · GHSA-72f5-rr8c-r6gr fluentd (RubyGems) Fixed in 1.19.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-44161
- 2026-10-03 Alias added: GHSA-72f5-rr8c-r6gr
References
Patch 2
More Fluentd vulnerabilities
- TI-2022-18753 Fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration) CVSS 3.1CRITICAL 9.8
- TI-2026-32064 Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder CVSS 3.1CRITICAL 9.8
- TI-2017-07995 Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may… CVSS 3.0CRITICAL 9.8
- TI-2020-14076 An issue was discovered in Fluent-ui v.1.2.2 allows attackers to gain escalated… CVSS 3.1HIGH 8.8
- TI-2026-32142 Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward` CVSS 3.1HIGH 7.5
- TI-2026-32065 Fluentd: Exposure of Sensitive Information via Monitor Agent API CVSS 3.1HIGH 7.5
Sources
- CVE-2026-44161 · CVE Program
- CVE-2026-44161 · NVD
- FIRST EPSS
- GHSA-72f5-rr8c-r6gr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences