Read the docs
TI-2023-04832 Aliases CVE-2023-5256GHSA-rjqg-3h9m-fx5x

Drupal core - Critical - Cache poisoning - SA-CORE-2023-006

Priority LOW 36CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

In certain scenarios, Drupal's JSON:API module will output error backtraces. With some configurations, this may cause sensitive information to be cached and made available to anonymous users, leading to privilege escalation. This vulnerability only affects sites with the JSON:API module enabled, and can be mitigated by uninstalling JSON:API. The core REST and contributed GraphQL modules are not affected.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00851 58th percentileScored 2026-11-07
Fix Fixed drupal/core (Packagist): 9.5.11, 10.0.11, 10.1.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalCore10.1 – 10.1.4; 10.0 – 10.0.11; 9.5 – 9.5.11—No fix listedCNA
—drupal/core (Packagist)8.7.0 to before 9.5.119.5.11Patch availableGHSA-rjqg-3h9m-fx5x
—drupal/core (Packagist)10.0.0 to before 10.0.1110.0.11Patch availableGHSA-rjqg-3h9m-fx5x
—drupal/core (Packagist)10.1.0 to before 10.1.410.1.4Patch availableGHSA-rjqg-3h9m-fx5x
  • Core VendorDrupal Affected 10.1 – 10.1.4; 10.0 – 10.0.11; 9.5 – 9.5.11 Fixed in — No fix listed CNA
  • drupal/core (Packagist) Vendor— Affected 8.7.0 to before 9.5.11 Fixed in 9.5.11 Patch available GHSA-rjqg-3h9m-fx5x
  • drupal/core (Packagist) Vendor— Affected 10.0.0 to before 10.0.11 Fixed in 10.0.11 Patch available GHSA-rjqg-3h9m-fx5x
  • drupal/core (Packagist) Vendor— Affected 10.1.0 to before 10.1.4 Fixed in 10.1.4 Patch available GHSA-rjqg-3h9m-fx5x

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*8.7.0 to before 9.5.11; 10.0.0 to before 10.0.11; 10.1.0 to before 10.1.4VulnerableDrupal
  • cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.7.0 to before 9.5.11; 10.0.0 to before 10.0.11; 10.1.0 to before 10.1.4 Vulnerable ·Drupal

Remediation

  • Fix · GHSA-rjqg-3h9m-fx5x drupal/core (Packagist) Fixed in 9.5.11 Advisory →
  • Fix · GHSA-rjqg-3h9m-fx5x drupal/core (Packagist) Fixed in 10.0.11 Advisory →
  • Fix · GHSA-rjqg-3h9m-fx5x drupal/core (Packagist) Fixed in 10.1.4 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-5256
  2. 2026-10-03 Alias added: GHSA-rjqg-3h9m-fx5x

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
See all 278 →

Sources