Read the docs
TI-2023-15969 Aliases CVE-2023-32693GHSA-469h-mqg8-535r

Decidim Cross-site Scripting vulnerability in the external link redirections

Priority LOW 39CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The external link feature is susceptible to cross-site scripting. This allows a remote attacker to execute JavaScript code in the context of a currently logged-in user. An attacker could use this vulnerability to make other users endorse or support proposals they have no intention of supporting or endorsing. The problem was patched in versions 0.27.3 and 0.26.7.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00816 57th percentileScored 2026-11-07
Fix Fixed decidim (decidim): 0.26.7, 0.27.3decidim (RubyGems): 0.26.7, 0.27.3+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
decidimdecidim0.25.0 to before 0.26.7; 0.27.0 to before 0.27.30.26.7, 0.27.3Patch availableCNA
—decidim (RubyGems)0.25.0 to before 0.26.70.26.7Patch availableGHSA-469h-mqg8-535r
—decidim-core (RubyGems)0.27.0 to before 0.27.30.27.3Patch availableGHSA-469h-mqg8-535r
—decidim-core (RubyGems)0.25.0 to before 0.26.70.26.7Patch availableGHSA-469h-mqg8-535r
—decidim (RubyGems)0.27.0 to before 0.27.30.27.3Patch availableGHSA-469h-mqg8-535r
  • decidim Vendordecidim Affected 0.25.0 to before 0.26.7; 0.27.0 to before 0.27.3 Fixed in 0.26.7, 0.27.3 Patch available CNA
  • decidim (RubyGems) Vendor— Affected 0.25.0 to before 0.26.7 Fixed in 0.26.7 Patch available GHSA-469h-mqg8-535r
  • decidim-core (RubyGems) Vendor— Affected 0.27.0 to before 0.27.3 Fixed in 0.27.3 Patch available GHSA-469h-mqg8-535r
  • decidim-core (RubyGems) Vendor— Affected 0.25.0 to before 0.26.7 Fixed in 0.26.7 Patch available GHSA-469h-mqg8-535r
  • decidim (RubyGems) Vendor— Affected 0.27.0 to before 0.27.3 Fixed in 0.27.3 Patch available GHSA-469h-mqg8-535r

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:decidim:decidim:*:*:*:*:*:ruby:*:*before 0.26.7; 0.27.0 to before 0.27.3Vulnerabledecidim
  • cpe:2.3:a:decidim:decidim:*:*:*:*:*:ruby:*:* Versions before 0.26.7; 0.27.0 to before 0.27.3 Vulnerable ·decidim

Remediation

  • Fix · CNA decidim (decidim) Fixed in 0.26.7, 0.27.3
  • Fix · GHSA-469h-mqg8-535r decidim (RubyGems) Fixed in 0.26.7 Advisory →
  • Fix · GHSA-469h-mqg8-535r decidim-core (RubyGems) Fixed in 0.27.3 Advisory →
  • Fix · GHSA-469h-mqg8-535r decidim-core (RubyGems) Fixed in 0.26.7 Advisory →
  • Fix · GHSA-469h-mqg8-535r decidim (RubyGems) Fixed in 0.27.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-32693
  2. 2026-10-03 Alias added: GHSA-469h-mqg8-535r

References

  • TI-2025-40203 Decidim's private data exports can lead to data leaks CVSS 4.0HIGH 8.2
  • TI-2023-16936 Decidim vulnerable to sensitive data disclosure CVSS 3.1HIGH 7.5
  • TI-2026-19249 Decidim has a Cross-site scripting (XSS) vulnerability via user name field CVSS 4.0CRITICAL 9.3
  • TI-2023-18306 Decidim has broken access control in templates CVSS 3.1CRITICAL 9.1
  • TI-2023-16935 Decidim Cross-site Scripting vulnerability in the processes filter CVSS 3.1HIGH 8.1
  • TI-2026-29525 Decidim amendments can be accepted or rejected by anyone CVSS 3.1HIGH 7.5
See all 14 →

Sources