Read the docs
TI-2023-16936 Aliases CVE-2023-34090GHSA-jm79-9pm4-vrw9

Decidim vulnerable to sensitive data disclosure

Priority MEDIUM 41CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.

Summary

Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. Decidim uses a third-party library named Ransack for filtering certain database collections (e.g., public meetings). By default, this library allows filtering on all data attributes and associations. This allows an unauthenticated remote attacker to exfiltrate non-public data from the underlying database of a Decidim instance (e.g., exfiltrating data from the user table). This issue may lead to Sensitive Data Disclosure. The problem was patched in version 0.27.3.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0126 69th percentileScored 2026-11-07
Fix Fixed decidim (decidim): 0.27.3decidim (RubyGems): 0.27.3+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
decidimdecidim0.27.0 to before 0.27.30.27.3Patch availableCNA
—decidim (RubyGems)0.27.0 to before 0.27.30.27.3Patch availableGHSA-jm79-9pm4-vrw9
—decidim-meetings (RubyGems)0.27.0 to before 0.27.30.27.3Patch availableGHSA-jm79-9pm4-vrw9
  • decidim Vendordecidim Affected 0.27.0 to before 0.27.3 Fixed in 0.27.3 Patch available CNA
  • decidim (RubyGems) Vendor— Affected 0.27.0 to before 0.27.3 Fixed in 0.27.3 Patch available GHSA-jm79-9pm4-vrw9
  • decidim-meetings (RubyGems) Vendor— Affected 0.27.0 to before 0.27.3 Fixed in 0.27.3 Patch available GHSA-jm79-9pm4-vrw9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:decidim:decidim:*:*:*:*:*:ruby:*:*before 0.27.3Vulnerabledecidim
  • cpe:2.3:a:decidim:decidim:*:*:*:*:*:ruby:*:* Versions before 0.27.3 Vulnerable ·decidim

Remediation

  • Fix · CNA decidim (decidim) Fixed in 0.27.3
  • Fix · GHSA-jm79-9pm4-vrw9 decidim (RubyGems) Fixed in 0.27.3 Advisory →
  • Fix · GHSA-jm79-9pm4-vrw9 decidim-meetings (RubyGems) Fixed in 0.27.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-34090
  2. 2026-10-03 Alias added: GHSA-jm79-9pm4-vrw9

References

  • TI-2025-40203 Decidim's private data exports can lead to data leaks CVSS 4.0HIGH 8.2
  • TI-2026-19249 Decidim has a Cross-site scripting (XSS) vulnerability via user name field CVSS 4.0CRITICAL 9.3
  • TI-2023-18306 Decidim has broken access control in templates CVSS 3.1CRITICAL 9.1
  • TI-2023-16935 Decidim Cross-site Scripting vulnerability in the processes filter CVSS 3.1HIGH 8.1
  • TI-2023-15969 Decidim Cross-site Scripting vulnerability in the external link redirections CVSS 3.1HIGH 8.1
  • TI-2026-29525 Decidim amendments can be accepted or rejected by anyone CVSS 3.1HIGH 7.5
See all 14 →

Sources