Read the docs
TI-2023-18306 Aliases CVE-2023-36465GHSA-639h-86hw-qcjq

Decidim has broken access control in templates

Priority MEDIUM 40CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · High · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-284.

Summary

Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. The `templates` module doesn't enforce the correct permissions, allowing any logged-in user to access to this functionality in the administration panel. An attacker could use this vulnerability to change, create or delete templates of surveys. This issue has been patched in version 0.26.8 and 0.27.4.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00674 52nd percentileScored 2026-11-07
Fix Fixed decidim (decidim): 0.26.8, 0.27.4decidim (RubyGems): 0.26.8, 0.27.4+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
decidimdecidim0.23.2 to before 0.26.8; 0.27.0 to before 0.27.40.26.8, 0.27.4Patch availableCNA
—decidim (RubyGems)0.23.2 to before 0.26.80.26.8Patch availableGHSA-639h-86hw-qcjq
—decidim-templates (RubyGems)0.23.2 to before 0.26.80.26.8Patch availableGHSA-639h-86hw-qcjq
—decidim-templates (RubyGems)0.27.0 to before 0.27.40.27.4Patch availableGHSA-639h-86hw-qcjq
—decidim (RubyGems)0.27.0 to before 0.27.40.27.4Patch availableGHSA-639h-86hw-qcjq
  • decidim Vendordecidim Affected 0.23.2 to before 0.26.8; 0.27.0 to before 0.27.4 Fixed in 0.26.8, 0.27.4 Patch available CNA
  • decidim (RubyGems) Vendor— Affected 0.23.2 to before 0.26.8 Fixed in 0.26.8 Patch available GHSA-639h-86hw-qcjq
  • decidim-templates (RubyGems) Vendor— Affected 0.23.2 to before 0.26.8 Fixed in 0.26.8 Patch available GHSA-639h-86hw-qcjq
  • decidim-templates (RubyGems) Vendor— Affected 0.27.0 to before 0.27.4 Fixed in 0.27.4 Patch available GHSA-639h-86hw-qcjq
  • decidim (RubyGems) Vendor— Affected 0.27.0 to before 0.27.4 Fixed in 0.27.4 Patch available GHSA-639h-86hw-qcjq

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:decidim:decidim:*:*:*:*:*:ruby:*:*before 0.26.8; 0.27.0 to before 0.27.4Vulnerabledecidim
  • cpe:2.3:a:decidim:decidim:*:*:*:*:*:ruby:*:* Versions before 0.26.8; 0.27.0 to before 0.27.4 Vulnerable ·decidim

Remediation

  • Fix · CNA decidim (decidim) Fixed in 0.26.8, 0.27.4
  • Fix · GHSA-639h-86hw-qcjq decidim (RubyGems) Fixed in 0.26.8 Advisory →
  • Fix · GHSA-639h-86hw-qcjq decidim-templates (RubyGems) Fixed in 0.26.8 Advisory →
  • Fix · GHSA-639h-86hw-qcjq decidim-templates (RubyGems) Fixed in 0.27.4 Advisory →
  • Fix · GHSA-639h-86hw-qcjq decidim (RubyGems) Fixed in 0.27.4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-36465
  2. 2026-10-03 Alias added: GHSA-639h-86hw-qcjq
  3. 2026-10-06 EPSS moved to the 50th–90th percentile

References

  • TI-2025-40203 Decidim's private data exports can lead to data leaks CVSS 4.0HIGH 8.2
  • TI-2023-16936 Decidim vulnerable to sensitive data disclosure CVSS 3.1HIGH 7.5
  • TI-2026-19249 Decidim has a Cross-site scripting (XSS) vulnerability via user name field CVSS 4.0CRITICAL 9.3
  • TI-2023-16935 Decidim Cross-site Scripting vulnerability in the processes filter CVSS 3.1HIGH 8.1
  • TI-2023-15969 Decidim Cross-site Scripting vulnerability in the external link redirections CVSS 3.1HIGH 8.1
  • TI-2026-29525 Decidim amendments can be accepted or rejected by anyone CVSS 3.1HIGH 7.5
See all 14 →

Sources