Decidim has a Cross-site scripting (XSS) vulnerability via user name field
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Decidim is a participatory democracy framework. In versions below 0.30.5 and 0.31.0.rc1 through 0.31.0, a stored code execution vulnerability in the user name field allows a low-privileged attacker to execute arbitrary code in the context of any user who passively visits a comment page, resulting in high confidentiality and integrity impact across security boundaries. This issue has been fixed in versions 0.30.5 and 0.31.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| decidim | decidim | 0.31.0.rc1 to before 0.31.1; before 0.30.5 | 0.31.1, 0.30.5 | Patch available | CNA |
| — | decidim-core (RubyGems) | 0.31.0.rc1 to before 0.31.1 | 0.31.1 | Patch available | GHSA-fc46-r95f-hq7g |
| — | decidim-core (RubyGems) | before 0.30.5 | 0.30.5 | Patch available | GHSA-fc46-r95f-hq7g |
- decidim Vendordecidim Affected 0.31.0.rc1 to before 0.31.1; before 0.30.5 Fixed in 0.31.1, 0.30.5 Patch available CNA
- decidim-core (RubyGems) Vendor— Affected 0.31.0.rc1 to before 0.31.1 Fixed in 0.31.1 Patch available GHSA-fc46-r95f-hq7g
- decidim-core (RubyGems) Vendor— Affected before 0.30.5 Fixed in 0.30.5 Patch available GHSA-fc46-r95f-hq7g
Remediation
- Fix · CNA decidim (decidim) Fixed in 0.31.1, 0.30.5
- Fix · GHSA-fc46-r95f-hq7g decidim-core (RubyGems) Fixed in 0.31.1 Advisory →
- Fix · GHSA-fc46-r95f-hq7g decidim-core (RubyGems) Fixed in 0.30.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-23891
- 2026-10-03 Alias added: GHSA-fc46-r95f-hq7g
References
Advisory 2
More Decidim vulnerabilities
- TI-2025-40203 Decidim's private data exports can lead to data leaks CVSS 4.0HIGH 8.2
- TI-2023-16936 Decidim vulnerable to sensitive data disclosure CVSS 3.1HIGH 7.5
- TI-2023-18306 Decidim has broken access control in templates CVSS 3.1CRITICAL 9.1
- TI-2023-16935 Decidim Cross-site Scripting vulnerability in the processes filter CVSS 3.1HIGH 8.1
- TI-2023-15969 Decidim Cross-site Scripting vulnerability in the external link redirections CVSS 3.1HIGH 8.1
- TI-2026-29525 Decidim amendments can be accepted or rejected by anyone CVSS 3.1HIGH 7.5
Sources
- CVE-2026-23891 · CVE Program
- CVE-2026-23891 · NVD
- FIRST EPSS
- GHSA-fc46-r95f-hq7g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences