Read the docs
TI-2026-29525 Aliases CVE-2026-40869GHSA-w5xj-99cg-rccm

Decidim amendments can be accepted or rejected by anyone

Priority LOW 38CWE-266Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Privilege escalation
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-266.

Summary

Decidim is a participatory democracy framework. Starting in version 0.19.0 and prior to versions 0.30.5 and 0.31.1, a vulnerability allows any registered and authenticated user to accept or reject any amendments. The impact is on any users who have created proposals where the amendments feature is enabled. This also elevates the user accepting the amendment as the author of the original proposal as people amending proposals are provided coauthorship on the coauthorable resources. Versions 0.30.5 and 0.31.1 fix the issue. As a workaround, disable amendment reactions for the amendable component (e.g. proposals).

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00223 12th percentileScored 2026-11-07
Fix Fixed decidim (decidim): 0.31.1, 0.30.5decidim-core (RubyGems): 0.31.1, 0.30.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
decidimdecidim0.31.0.rc1 to before 0.31.1; 0.19.0 to before 0.30.50.31.1, 0.30.5Patch availableCNA
—decidim-core (RubyGems)0.31.0.rc1 to before 0.31.10.31.1Patch availableGHSA-w5xj-99cg-rccm
—decidim-core (RubyGems)0.19.0 to before 0.30.50.30.5Patch availableGHSA-w5xj-99cg-rccm
  • decidim Vendordecidim Affected 0.31.0.rc1 to before 0.31.1; 0.19.0 to before 0.30.5 Fixed in 0.31.1, 0.30.5 Patch available CNA
  • decidim-core (RubyGems) Vendor— Affected 0.31.0.rc1 to before 0.31.1 Fixed in 0.31.1 Patch available GHSA-w5xj-99cg-rccm
  • decidim-core (RubyGems) Vendor— Affected 0.19.0 to before 0.30.5 Fixed in 0.30.5 Patch available GHSA-w5xj-99cg-rccm

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:decidim:decidim:*:*:*:*:*:ruby:*:*0.19.0 to before 0.30.5; 0.31.0 to before 0.31.1Vulnerabledecidim
  • cpe:2.3:a:decidim:decidim:*:*:*:*:*:ruby:*:* Versions 0.19.0 to before 0.30.5; 0.31.0 to before 0.31.1 Vulnerable ·decidim

Remediation

  • Fix · CNA decidim (decidim) Fixed in 0.31.1, 0.30.5
  • Fix · GHSA-w5xj-99cg-rccm decidim-core (RubyGems) Fixed in 0.31.1 Advisory →
  • Fix · GHSA-w5xj-99cg-rccm decidim-core (RubyGems) Fixed in 0.30.5 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-40869
  2. 2026-10-03 Alias added: GHSA-w5xj-99cg-rccm

References

  • TI-2025-40203 Decidim's private data exports can lead to data leaks CVSS 4.0HIGH 8.2
  • TI-2023-16936 Decidim vulnerable to sensitive data disclosure CVSS 3.1HIGH 7.5
  • TI-2026-19249 Decidim has a Cross-site scripting (XSS) vulnerability via user name field CVSS 4.0CRITICAL 9.3
  • TI-2023-18306 Decidim has broken access control in templates CVSS 3.1CRITICAL 9.1
  • TI-2023-16935 Decidim Cross-site Scripting vulnerability in the processes filter CVSS 3.1HIGH 8.1
  • TI-2023-15969 Decidim Cross-site Scripting vulnerability in the external link redirections CVSS 3.1HIGH 8.1
See all 14 →

Sources