In Langchain through 0.0.155, prompt injection allows an attacker to force the service to…
Priority MEDIUM 40CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.
Summary
In Langchain through 0.0.155, prompt injection allows an attacker to force the service to retrieve data from an arbitrary URL, essentially providing SSRF and potentially injecting content into downstream tasks.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00709 53rd percentileScored 2026-11-07
Fix Fixed langchain (PyPI): 0.0.329
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | langchain (PyPI) | before 0.0.329 | 0.0.329 | Patch available | GHSA-6h8p-4hx9-w66c |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- langchain (PyPI) Vendor— Affected before 0.0.329 Fixed in 0.0.329 Patch available GHSA-6h8p-4hx9-w66c
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:langchain:langchain:*:*:*:*:*:*:*:* | up to 0.0.155 | Vulnerable | langchain-ai |
- cpe:2.3:a:langchain:langchain:*:*:*:*:*:*:*:* Versions up to 0.0.155 Vulnerable ·langchain-ai
Remediation
- Fix · GHSA-6h8p-4hx9-w66c langchain (PyPI) Fixed in 0.0.329 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32786
- 2026-10-03 Alias added: GHSA-6h8p-4hx9-w66c
References
More langchain-ai Langchain vulnerabilities
- TI-2023-20724 An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2023-20706 An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2023-20166 An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2023-20136 An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter. CVSS 3.1CRITICAL 9.8
- TI-2023-18185 An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a… CVSS 3.1CRITICAL 9.8
- TI-2023-18176 An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-32786 · CVE Program
- CVE-2023-32786 · NVD
- FIRST EPSS
- GHSA-6h8p-4hx9-w66c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences