Read the docs
TI-2023-17309 Aliases CVE-2023-34540GHSA-x32c-59v5-h7fg

Langchain before v0.0.225 was discovered to contain a remote code execution (RCE)…

Priority MEDIUM 45CWE-78Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.

Summary

Langchain before v0.0.225 was discovered to contain a remote code execution (RCE) vulnerability in the component JiraAPIWrapper (aka the JIRA API wrapper). This vulnerability allows attackers to execute arbitrary code via crafted input. As noted in the "releases/tag" reference, a fix is available.

Why it matters now

EPSS 0.01667 76th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed langchain (PyPI): 0.0.225

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—langchain (PyPI)before 0.0.2250.0.225Patch availableGHSA-x32c-59v5-h7fg
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • langchain (PyPI) Vendor— Affected before 0.0.225 Fixed in 0.0.225 Patch available GHSA-x32c-59v5-h7fg

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:langchain:langchain:0.0.171:*:*:*:*:*:*:*0.0.171Vulnerablelangchain-ai
  • cpe:2.3:a:langchain:langchain:0.0.171:*:*:*:*:*:*:* Versions 0.0.171 Vulnerable ·langchain-ai

Remediation

  • Fix · GHSA-x32c-59v5-h7fg langchain (PyPI) Fixed in 0.0.225 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-34540
  2. 2026-10-03 Alias added: GHSA-x32c-59v5-h7fg

References

  • TI-2023-20724 An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
  • TI-2023-20706 An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
  • TI-2023-20166 An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
  • TI-2023-20136 An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter. CVSS 3.1CRITICAL 9.8
  • TI-2023-18185 An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a… CVSS 3.1CRITICAL 9.8
  • TI-2023-18176 An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because… CVSS 3.1CRITICAL 9.8
See all 27 →

Sources