Read the docs
TI-2023-18115 Aliases CVE-2023-36095GHSA-gwqq-6vq7-5j86

An issue in Harrison Chase langchain v.0.0.194 allows an attacker to execute arbitrary…

Priority HIGH 82CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

An issue in Harrison Chase langchain v.0.0.194 allows an attacker to execute arbitrary code via the python exec calls in the PALChain, affected functions include from_math_prompt and from_colored_object_prompt.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0117 67th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed langchain (PyPI): 0.0.236

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—langchain (PyPI)before 0.0.2360.0.236Patch availableGHSA-gwqq-6vq7-5j86
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • langchain (PyPI) Vendor— Affected before 0.0.236 Fixed in 0.0.236 Patch available GHSA-gwqq-6vq7-5j86

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:langchain:langchain:0.0.194:*:*:*:*:*:*:*0.0.194Vulnerablelangchain-ai
  • cpe:2.3:a:langchain:langchain:0.0.194:*:*:*:*:*:*:* Versions 0.0.194 Vulnerable ·langchain-ai

Remediation

  • Fix · GHSA-gwqq-6vq7-5j86 langchain (PyPI) Fixed in 0.0.236 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-36095
  2. 2026-10-03 Alias added: GHSA-gwqq-6vq7-5j86

References

  • TI-2023-20724 An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
  • TI-2023-20706 An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
  • TI-2023-20166 An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
  • TI-2023-20136 An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter. CVSS 3.1CRITICAL 9.8
  • TI-2023-18185 An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a… CVSS 3.1CRITICAL 9.8
  • TI-2023-18176 An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because… CVSS 3.1CRITICAL 9.8
See all 27 →

Sources