SQL injection vulnerability in langchain before v0.0.247 allows a remote attacker to…
Priority MEDIUM 41CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
SQL injection vulnerability in langchain before v0.0.247 allows a remote attacker to obtain sensitive information via the SQLDatabaseChain component.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01237 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed langchain (PyPI): 0.0.247
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | langchain (PyPI) | before 0.0.247 | 0.0.247 | Patch available | GHSA-7q94-qpjr-xpgm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- langchain (PyPI) Vendor— Affected before 0.0.247 Fixed in 0.0.247 Patch available GHSA-7q94-qpjr-xpgm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:langchain:langchain:0.0.64:*:*:*:*:*:*:* | 0.0.64 | Vulnerable | langchain-ai |
- cpe:2.3:a:langchain:langchain:0.0.64:*:*:*:*:*:*:* Versions 0.0.64 Vulnerable ·langchain-ai
Remediation
- Fix · GHSA-7q94-qpjr-xpgm langchain (PyPI) Fixed in 0.0.247 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-36189
- 2026-10-03 Alias added: GHSA-7q94-qpjr-xpgm
References
Other 7
- https://gist.github.com/rharang/9c58d39db8c01db5b7c888e467c0533f
- https://github.com/langchain-ai/langchain/issues/5923#issuecomment-1696053841
- https://github.com/langchain-ai/langchain/issues/5923
- https://github.com/langchain-ai/langchain/pull/8425
- https://github.com/langchain-ai/langchain/commit/fab24457bcf8ede882abd11419769c92bc4e7751
- https://github.com/langchain-ai/langchain
- https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-110.yaml
More langchain-ai Langchain vulnerabilities
- TI-2023-20724 An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2023-20706 An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2023-20166 An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2023-20136 An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter. CVSS 3.1CRITICAL 9.8
- TI-2023-18185 An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a… CVSS 3.1CRITICAL 9.8
- TI-2023-18176 An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-36189 · CVE Program
- CVE-2023-36189 · NVD
- FIRST EPSS
- GHSA-7q94-qpjr-xpgm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences