Read the docs
TI-2023-24579 Aliases CVE-2023-45819GHSA-hgqx-r2hp-jr38

Cross-site Scripting vulnerability in TinyMCE notificationManager.open API

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s Notification Manager API. The vulnerability exploits TinyMCE's unfiltered notification system, which is used in error handling. The conditions for this exploit requires carefully crafted malicious content to have been inserted into the editor and a notification to have been triggered. When a notification was opened, the HTML within the text argument was displayed unfiltered in the notification. The vulnerability allowed arbitrary JavaScript execution when an notification presented in the TinyMCE UI for the current user. This issue could also be exploited by any integration which uses a TinyMCE notification to display unfiltered HTML content. This vulnerability has been patched in TinyMCE 5.10.8 and TinyMCE 6.7.1 by ensuring that the HTML displayed in the notification is sanitized, preventing the exploit. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00634 50th percentileScored 2026-11-07
Fix Fixed tinymce (tinymce): 5.10.8, 6.7.1tinymce (npm): 6.7.1, 5.10.8+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
tinymcetinymcebefore 5.10.8; 6.0.0 to before 6.7.15.10.8, 6.7.1Patch availableCNA
—tinymce (npm)6.0.0 to before 6.7.16.7.1Patch availableGHSA-hgqx-r2hp-jr38
—TinyMCE (NuGet)6.0.0 to before 6.7.16.7.1Patch availableGHSA-hgqx-r2hp-jr38
—tinymce/tinymce (Packagist)6.0.0 to before 6.7.16.7.1Patch availableGHSA-hgqx-r2hp-jr38
—tinymce (npm)before 5.10.85.10.8Patch availableGHSA-hgqx-r2hp-jr38
—TinyMCE (NuGet)before 5.10.85.10.8Patch availableGHSA-hgqx-r2hp-jr38
—tinymce/tinymce (Packagist)before 5.10.85.10.8Patch availableGHSA-hgqx-r2hp-jr38
  • tinymce Vendortinymce Affected before 5.10.8; 6.0.0 to before 6.7.1 Fixed in 5.10.8, 6.7.1 Patch available CNA
  • tinymce (npm) Vendor— Affected 6.0.0 to before 6.7.1 Fixed in 6.7.1 Patch available GHSA-hgqx-r2hp-jr38
  • TinyMCE (NuGet) Vendor— Affected 6.0.0 to before 6.7.1 Fixed in 6.7.1 Patch available GHSA-hgqx-r2hp-jr38
  • tinymce/tinymce (Packagist) Vendor— Affected 6.0.0 to before 6.7.1 Fixed in 6.7.1 Patch available GHSA-hgqx-r2hp-jr38
  • tinymce (npm) Vendor— Affected before 5.10.8 Fixed in 5.10.8 Patch available GHSA-hgqx-r2hp-jr38
  • TinyMCE (NuGet) Vendor— Affected before 5.10.8 Fixed in 5.10.8 Patch available GHSA-hgqx-r2hp-jr38
  • tinymce/tinymce (Packagist) Vendor— Affected before 5.10.8 Fixed in 5.10.8 Patch available GHSA-hgqx-r2hp-jr38

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:*before 5.10.8; 6.0.0 to before 6.7.1VulnerableTiny
  • cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:* Versions before 5.10.8; 6.0.0 to before 6.7.1 Vulnerable ·Tiny

Remediation

  • Fix · CNA tinymce (tinymce) Fixed in 5.10.8, 6.7.1
  • Fix · GHSA-hgqx-r2hp-jr38 tinymce (npm) Fixed in 6.7.1 Advisory →
  • Fix · GHSA-hgqx-r2hp-jr38 TinyMCE (NuGet) Fixed in 6.7.1 Advisory →
  • Fix · GHSA-hgqx-r2hp-jr38 tinymce/tinymce (Packagist) Fixed in 6.7.1 Advisory →
  • Fix · GHSA-hgqx-r2hp-jr38 tinymce (npm) Fixed in 5.10.8 Advisory →
  • Fix · GHSA-hgqx-r2hp-jr38 TinyMCE (NuGet) Fixed in 5.10.8 Advisory →
  • Fix · GHSA-hgqx-r2hp-jr38 tinymce/tinymce (Packagist) Fixed in 5.10.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-45819
  2. 2026-10-03 Alias added: GHSA-hgqx-r2hp-jr38
  3. 2026-10-25 EPSS moved to the 50th–90th percentile

References

  • TI-2011-04153 Static code injection vulnerability in inc/function.base.php in Ajax File and Image… CVSS 2.0HIGH 7.5
  • TI-2026-81439 Cross-site scripting in TinyMCE media plugin via data-mce-object CVSS 4.0HIGH 8.5
  • TI-2026-35259 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments CVSS 3.1HIGH 8.7
  • TI-2026-35258 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection CVSS 3.1HIGH 8.7
  • TI-2026-35256 TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes CVSS 3.1HIGH 8.7
  • TI-2026-35257 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs CVSS 3.1HIGH 8.7
See all 20 →

Sources