Read the docs
TI-2023-25775 Aliases CVE-2023-47634GHSA-r275-j57c-7mf2

Decidim has race condition in Endorsements

Priority LOW 16CWE-362Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

Decidim is a participatory democracy framework. Starting in version 0.10.0 and prior to versions 0.26.9, 0.27.5, and 0.28.0, a race condition in the endorsement of resources (for instance, a proposal) allows a user to make more than once endorsement. To exploit this vulnerability, the request to set an endorsement must be sent several times in parallel. Versions 0.26.9, 0.27.5, and 0.28.0 contain a patch for this issue. As a workaround, disable the Endorsement feature in the components.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00444 38th percentileScored 2026-11-07
Fix Fixed decidim (decidim): 0.26.9, 0.27.5decidim (RubyGems): 0.26.9, 0.27.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
decidimdecidim0.10.0 to before 0.26.9; 0.27.0 to before 0.27.50.26.9, 0.27.5Patch availableCNA
—decidim (RubyGems)0.10.0 to before 0.26.90.26.9Patch availableGHSA-r275-j57c-7mf2
—decidim (RubyGems)0.27.0 to before 0.27.50.27.5Patch availableGHSA-r275-j57c-7mf2
  • decidim Vendordecidim Affected 0.10.0 to before 0.26.9; 0.27.0 to before 0.27.5 Fixed in 0.26.9, 0.27.5 Patch available CNA
  • decidim (RubyGems) Vendor— Affected 0.10.0 to before 0.26.9 Fixed in 0.26.9 Patch available GHSA-r275-j57c-7mf2
  • decidim (RubyGems) Vendor— Affected 0.27.0 to before 0.27.5 Fixed in 0.27.5 Patch available GHSA-r275-j57c-7mf2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:decidim:decidim:*:*:*:*:*:ruby:*:*0.10.0 to before 0.26.9; 0.27.0 to before 0.27.5Vulnerabledecidim
  • cpe:2.3:a:decidim:decidim:*:*:*:*:*:ruby:*:* Versions 0.10.0 to before 0.26.9; 0.27.0 to before 0.27.5 Vulnerable ·decidim

Remediation

  • Fix · CNA decidim (decidim) Fixed in 0.26.9, 0.27.5
  • Fix · GHSA-r275-j57c-7mf2 decidim (RubyGems) Fixed in 0.26.9 Advisory →
  • Fix · GHSA-r275-j57c-7mf2 decidim (RubyGems) Fixed in 0.27.5 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-47634
  2. 2026-10-03 Alias added: GHSA-r275-j57c-7mf2

References

  • TI-2025-40203 Decidim's private data exports can lead to data leaks CVSS 4.0HIGH 8.2
  • TI-2023-16936 Decidim vulnerable to sensitive data disclosure CVSS 3.1HIGH 7.5
  • TI-2026-19249 Decidim has a Cross-site scripting (XSS) vulnerability via user name field CVSS 4.0CRITICAL 9.3
  • TI-2023-18306 Decidim has broken access control in templates CVSS 3.1CRITICAL 9.1
  • TI-2023-16935 Decidim Cross-site Scripting vulnerability in the processes filter CVSS 3.1HIGH 8.1
  • TI-2023-15969 Decidim Cross-site Scripting vulnerability in the external link redirections CVSS 3.1HIGH 8.1
See all 14 →

Sources