Read the docs
TI-2023-26083 Aliases CVE-2023-48219GHSA-v626-r774-j7f8

Special characters in unescaped text nodes can trigger mXSS in TinyMCE

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

TinyMCE is an open source rich text editor. A mutation cross-site scripting (mXSS) vulnerability was discovered in TinyMCE’s core undo/redo functionality and other APIs and plugins. Text nodes within specific parents are not escaped upon serialization according to the HTML standard. If such text nodes contain a special character reserved as an internal marker, they can be combined with other HTML patterns to form malicious snippets. These snippets pass the initial sanitisation layer when the content is parsed into the editor body, but can trigger XSS when the special internal marker is removed from the content and re-parsed. his vulnerability has been patched in TinyMCE versions 6.7.3 and 5.10.9. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00715 53rd percentileScored 2026-11-07
Fix Fixed tinymce (tinymce): 5.10.9tinymce (npm): 5.10.9, 6.7.3+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
tinymcetinymce>= 6.0.0 < 6.7.3; before 5.10.95.10.9Patch availableCNA
—tinymce (npm)before 5.10.95.10.9Patch availableGHSA-v626-r774-j7f8
—tinymce (npm)6.0.0 to before 6.7.36.7.3Patch availableGHSA-v626-r774-j7f8
—tinymce/tinymce (Packagist)before 5.10.95.10.9Patch availableGHSA-v626-r774-j7f8
—tinymce/tinymce (Packagist)6.0.0 to before 6.7.36.7.3Patch availableGHSA-v626-r774-j7f8
—TinyMCE (NuGet)before 5.10.95.10.9Patch availableGHSA-v626-r774-j7f8
—TinyMCE (NuGet)6.0.0 to before 6.7.36.7.3Patch availableGHSA-v626-r774-j7f8
  • tinymce Vendortinymce Affected >= 6.0.0 < 6.7.3; before 5.10.9 Fixed in 5.10.9 Patch available CNA
  • tinymce (npm) Vendor— Affected before 5.10.9 Fixed in 5.10.9 Patch available GHSA-v626-r774-j7f8
  • tinymce (npm) Vendor— Affected 6.0.0 to before 6.7.3 Fixed in 6.7.3 Patch available GHSA-v626-r774-j7f8
  • tinymce/tinymce (Packagist) Vendor— Affected before 5.10.9 Fixed in 5.10.9 Patch available GHSA-v626-r774-j7f8
  • tinymce/tinymce (Packagist) Vendor— Affected 6.0.0 to before 6.7.3 Fixed in 6.7.3 Patch available GHSA-v626-r774-j7f8
  • TinyMCE (NuGet) Vendor— Affected before 5.10.9 Fixed in 5.10.9 Patch available GHSA-v626-r774-j7f8
  • TinyMCE (NuGet) Vendor— Affected 6.0.0 to before 6.7.3 Fixed in 6.7.3 Patch available GHSA-v626-r774-j7f8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:*before 5.10.9; 6.0.0 to before 6.7.3VulnerableTiny
  • cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:* Versions before 5.10.9; 6.0.0 to before 6.7.3 Vulnerable ·Tiny

Remediation

  • Fix · CNA tinymce (tinymce) Fixed in 5.10.9
  • Fix · GHSA-v626-r774-j7f8 tinymce (npm) Fixed in 5.10.9 Advisory →
  • Fix · GHSA-v626-r774-j7f8 tinymce (npm) Fixed in 6.7.3 Advisory →
  • Fix · GHSA-v626-r774-j7f8 tinymce/tinymce (Packagist) Fixed in 5.10.9 Advisory →
  • Fix · GHSA-v626-r774-j7f8 tinymce/tinymce (Packagist) Fixed in 6.7.3 Advisory →
  • Fix · GHSA-v626-r774-j7f8 TinyMCE (NuGet) Fixed in 5.10.9 Advisory →
  • Fix · GHSA-v626-r774-j7f8 TinyMCE (NuGet) Fixed in 6.7.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-48219
  2. 2026-10-03 Alias added: GHSA-v626-r774-j7f8

References

  • TI-2011-04153 Static code injection vulnerability in inc/function.base.php in Ajax File and Image… CVSS 2.0HIGH 7.5
  • TI-2026-81439 Cross-site scripting in TinyMCE media plugin via data-mce-object CVSS 4.0HIGH 8.5
  • TI-2026-35259 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments CVSS 3.1HIGH 8.7
  • TI-2026-35258 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection CVSS 3.1HIGH 8.7
  • TI-2026-35256 TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes CVSS 3.1HIGH 8.7
  • TI-2026-35257 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs CVSS 3.1HIGH 8.7
See all 20 →

Sources